No sound OpenSuse 11.1


moved from another thread:

" Originally Posted by a_whistler View Post
My first problem is, there is no sound. No matter what I do. I went through a lot of tutorials and checked many threads in this forum, but nothing made a beep.
What openSUSE version ? 11.0 ? 11.1 ? 11.2 ? It makes a difference. Please be certain to open your mixer (kmix in kde, alsa mixer in gnome) and unmute and move up the volume in master, PCM, and speaker (if there is such a setting). Note in kmix you can add additional channels to get more mixer controls.

Then take a look here: SDB:AudioTroubleshooting - openSUSE

Don’t spend too much time on this. If you can’t get it working right away, post and we can help you further. "

So, I’m using 11.1, and I worked my way through the SDB:AudioTroubleshooting without getting a single beep…

What kind of hardware information are necessary to solve this problem!? (Sorry, as I said, I only just started using openSuse.)


Well, guess we will see. Some how, I suspect you skipped some steps that you either did not understand or did not want to do , … but no worries. We will walk you thru again, some very specific parts of it.

First though, do you have any linux experience? If not, take a look at this to remove some of the mystery out of the magic users will be throwing at you:
Concepts - openSUSE

Please do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is “kmix” (the small speaker in right hand corner). In Gnome your mixer is “alsamixer”.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will ask you if you wish to share the information (select YES) and it will post its output on the Internet/web. And when finished it will give you the URL of the web site where the information is posted. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa ‘alsa
rpm -qa ‘pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a detailed recommendation. (but try the alsa-firmware installation/reboot first)

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.


I think I found the problem… I turned the volume on all the way and I heard a VERY faint “front right, front left”…

So I did what you told me and tried to start kmix… Which won’t work for some reason. The program just doesn’t start!

It accually shows the loading icon with the cursor, but that disappears after some time and nothing happens…

For my linux “knowledge”, we use solaris in college, so I know my way around the xterm… But I never had my own computer running linux before, so I’m new to the entire scene behind the curtain so to say ^^

Back to my problem, wouldn’t this kmix problem indicate that there is something really wrong with my kde!?

It seems that I just need to turn on the sound all the way…

Okay its solved, I found the system mixer in the menu… I still find it rather strange that kmix won’t start, but at least I can here stuff now.

Thanks a lot, even though it was kind of my own stupidity ^^

Take care,

Congratulations on sorting the problem and getting sound working. Thanks for sharing your solution.