No sound on YouTube

There’s no sound in Firefox!
Really, it works anywhere (VLC,Amarok,etc).
I’ve yet
–copied to /usr/bin/firefox/pluguns (I have had to create folder “plugins”);
–removed libflashsupport;
–turned on PCM,
but nothing’s changed.

What should I do?

Use openSuse 11.1, KDE.

Thanks for your help,

How many audio hardware devices do you have on your PC ? One or two ? If two, check to ensure the order of devices in KMenu (Kickoff launcher app) > Configure Desktop > General > Computer Adminstration > Multimedia is consistent with the order of devices in YaST > Hardware > Sound

I do not know anything about coping to /usr/bin/firefox/pluguns (creating folder “plugins”) … so I do not know if that would help, make it worse, or make no difference.

I have two sound cards, using Intel HDA as a default one.
But when I tried to open Configure Desktop> … > Multimedia, it shutted down suddenly,so I couldn’t check the order of the devices. Maybe, reboot will help me, maybe it’s time to sleep =)
2 AM is in Moscow now))))
Tomorrow I’ll be back. And thank you for your help!
Good night!

Reads like a KDE-4.1.3 bug of openSUSE-11.1.

Did you ever consider updating your openSUSE-11.1 KDE-4.1.3 to either KDE-4.3.4 or KDE-4.3.5 ? While normally I do NOT recommend KDE updates, … in this case given the significant improvement from KDE-4.1.3 to 4.3.x, it may be worth considering.

I think the KDE-4.3.5 apps are pretty good here in this repository, and one could add that repository, and then update to all the KDE apps on that repos …

BUT before doing so, I would post and check so that one of our KDE experts (of which I am not one) can pipe up and advise if (1) that is the correct repository for such an update, and (2) if this truly IS a good idea ?

I had this problem also when I first installed openSUSE 11.2, the fix is to go into yast->hardware->sound-> make sure your sound card is showing, then click the other tab-> volume and then turn PCM all the way up. Use test to verify that you have sound and then Have Fun in youtube! This only needs to be done once.

Good afternoon, oldcpu!
Yes, I unfortinately updated KDE to version 4.4.65 =(
So, I’ll not perform any update until your further recomendations.

Ahhh … I did not know KDE even went that high in version tracking ! :slight_smile: … If so, could it be then that you have a KDE-4.4.65 bug ? You may wish to raise a bug report on KDE-4.4.65

I have had this problem, and on my system it was a Flash bug. I killed firefox and reopened it and it worked fine. Unfortunately it is a frequent occurrence, and I have to do it every few days. Sometimes it has an annoying stutter, which is far worse than no sound at all (for example, if they say “open source” it will repeat enso enso enso enso for at least 30 seconds and then skip forward and do it with another segment of dialogue.) Killing Firefox cures it, but again for only a few days.

I am having an identical problem that started this morning. I agree that this may be a KDE problem as I update almost daily and all worked perfectly until today. Sound works in Firefox, other than flash sound. I can’t even get sound from a local flash video file opened in Firefox. I am able to play local flash video outside of Firefox with VLC media player. All other system sounds work as expected. This also affects Hulu Desktop.
My mixer doesn’t offer a pcm volume setting for me to check. The driver is snd-virtuoso. I have the mixer set to display all controls and see nothing concerning pcm.

Guess I’ll wait a few days and see if a patch shows up for this problem.

Did you check to see if you have the same order of devices in YaST > Hardware > Sound as you have in KDE under Configure Desktop > Multimedia ?

Should be related to KDE update to 4.4.1. No sound on YouTube starting from today :wink:

Investigating… (intel hda as well)

Yast has never been able to configure my sound card. It is seen as a Virtuoso 200 (Xonar D2X), which is correct. Any time I have tried to configure it through Yast, it fails. Since it is not configured in Yast, the “play test sound” and “volume” are not working. The card has worked correctly for over a year, including flash audio. KDE system settings sees it as an ASUS Virtuoso 200. Audio in all other packages works perfectly. Only flash audio in Firefox and Hulu desktop is affected. I have no audio from flash websites and no audio when playing a local flash file with Firefox.
To answer your question, yes the card is seen as primary in both Yast and KDE. Yast also sees an ATI Radeon HD 4850 (card is actually a 4870). I blacklisted the driver for that card 2 months ago because it gave me several headaches concerning sound.
Strangely, if I run alsaconf, alsa tells me that it can’t find a PNP sound card installed.
I would like to get rid of Pulse Audio completely, but if I remove it, alsa complains that it can’t find the alsa-pulse-plugin config file (if I remember correctly) and I lose all sound.
I am considering removing both alsa and pulse, then re-installing alsa.
As stated in my first post, this started just yesterday. I am fairly certain it was caused by an update, but I can’t be sure which one.

I forgot to point out that VLC works perfectly when playing a local flash file.

I did as I mentioned and removed both Pulse and Alsa, then re-installed alsa from Yast.
I followed the instructions in the “Check your multimedia problem in ten steps” forum to the letter. I had many packages from the Videolan repository installed and replaced them with the Packman equivalents. I also added the missing package gstreamer-plugins-ugly. After a reboot, the sound system did not work at all. VLC had all audio devices greyed out. I tried adding a sound card from scratch using Yast-sound. There was not a snd-virtuoso driver available. Yast wants to use the snd-oxygen driver with my card.
I then un-installed alsa again from Yast. I downloaded alsa directly from the alsa site and installed it, following the instructions for the snd-virtuoso driver. I reversed what I had done and reverted back to the VLC repository and removed the gstreamer packages that I had added.
All sound works perfectly now, without Pulse. Most of my audio is either 8 channel WMA files or 8 channel WAV. All play again. Flash audio now works again also in both Firefox and Hulu Desktop. After all was working, I went back into Yast and gave it another chance to configure my card. It still wants to configure the snd-oxygen driver for my card and ends with failure. Here is the output of the sound modules loaded:

lsmod | grep snd
snd_seq_oss 41376 0
snd_seq_midi_event 10888 1 snd_seq_oss
snd_seq 74368 4 snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 51328 0
snd_mixer_oss 22152 1 snd_pcm_oss
snd_virtuoso 29764 3
snd_oxygen_lib 45704 1 snd_virtuoso
snd_pcm 109360 3 snd_pcm_oss,snd_oxygen_lib
snd_timer 29176 3 snd_seq,snd_pcm
snd_page_alloc 12824 1 snd_pcm
snd_mpu401_uart 11144 1 snd_oxygen_lib
snd_rawmidi 31136 1 snd_mpu401_uart
snd_seq_device 10460 3 snd_seq_oss,snd_seq,snd_rawmidi
snd 84648 15 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_virtuoso,snd_oxygen_lib,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device

All seems to be working perfectly, so I will leave it alone.

You did not specifiy your openSUSE version but you should note that for openSUSE-11.2 (and later) alsaconf has beeb depreciated and should not be used. alsaconf writes to an /etc/modprobe.d/sound file which is NOT used in 11.2 (11.2 uses an /etc/modprobe.d/50-sound.conf).

Have you written a bug report on YaST’s inability to configure your sound card ?

Excellent !

One final question on my part. … why tag your problem on to this thread ?? Clearly its a different problem, yet I was forced to re-read all the previous posts in this thread to see if they had any relevance to your problem (because presumeably you had a good reason for taggin on to someone else’s problem). Yet after reading and re-reading. clearly they were not relevant, and it was a complete waste of time to have to re-read. As someone trying to support, I find that waste of time being forced (by the act of tagging on to another problem) very annoying.

Note tagging on to someone else’s problem often makes it harder to get good support.

I tagged my problem to this post because it seemed to be the same problem as the original author was having. I had no flash audio, while all other audio worked fine. It was not until I followed the instructions in the other forum that my audio became broken altogether.
I apologize. I should have started a new thread about Yast’s inability to configure my particular card, and replied to the other forum concerning the total loss of audio. I wasn’t thinking clearly.

No worries - You fixed the problem which is great ! and I think I was in a very poor grumpy mood that frankly speaking, reflects bad on me. Apologies for my previous post.

I’m very glad to read you had some success.

I reinstalled on a PC yesterday and was confronted with exactly this problem. Card a Xonar DX2, no sound on Youtube, and other web flash. Tried about every possible solution, nothing worked.
Then today, in some desperate ( not true, I know this place, so…) move, I decided to remove the config for the card in Yast, then reboot and see what happened, guess what? Sound all over the place, Youtube, no matter what.

Lee, AFAICS this happens: Yast sets the card to use the snd-oxygen module initially. It clearly says so. Anything you try errors out. Removing the card triggers autodetection on reboot(?), now snd-virtuoso is loaded, the card appears configured as sound card 0 in Yast, some volume setting can be done. So during install the wrong module is chosen, on removal of the config in Yast and reboot, it works correct. Is this a bug in HAL / Yast?

If it wasn’t a quite complex machine (one about like I have) we have been working on all yesterday evening and half of the night, I would have gladly tried to reproduce this, without all other “solutions”, just the removal of the cards config in Yast.

But, girls, guys, others, am I glad this place is there. :wink:

My guess is a sound bug, and not a YaST nor a HAL bug, but I could be wrong. I think its the alsa driver that YaST uses to identify the device (but I could be wrong). Its definitely a bug and deserves a bug report somewhere.

Also intel-hda sound here and Kde 4.4.1, and Flash works fine in Firefox 3.6 using the 64-bit flash plugin.

Are you using the 32-bit flash plugin? If yes, then you could try out the 64-bit version and see if it works.

  1. Close Firefox, if running
  2. Next, delete the in /usr/bin/firefox/plugins
  3. Then, download the 64-bit Flash plugin:
    Adobe Labs - Downloads: Flash Player 10 for 64-bit Linux
  4. Unzip the file and put it here: (create the folder if it doesn’t exist)
    /home/<your user name>/.mozilla/plugins
    In Dolphin, check View>Show Hidden Files to see directories and files starting with a ‘.’ (dot).
  5. Restart Firefox and check under Tools>Add-ons>Plugins that Flash is listed (should be 10.0 r45)

If that’s working for you, you can also get rid of nspluginwrapper.