No sound from sound card 0 in two card setup

For quite some time have not been able to use the mic on a Logitech web camera, apparently could not be found. I put this down to the beta version of skype.

The system has two (2) sound cards, 0 on motherboard and 1 on video card

Configuring the sound card in Yast it appears that whenever either sound card is configured as sound card 0 it does not work, no sound, no volume configuration menu. At the same time sound card 1 works, plays a sound but still no mic.

It would seem that this is a software issue as both cards play o.k. when configured as sound card 1 but the mic is not recognized. Video camera works o.k.

Not being able to find the mic was also a problem in 42.3 but did not track it down so far, attributed it to skype beta.

Have you tried configuring with pavucontrol?

reverted back to 42.3 and find exactly the same problem. we have exactly the same problem on our other box also running 42.3, no sound or volume menu on sound card 0, switching cards produces the same result

what is pavucontrol please ?? this looks as though it would take more than fiddling with settings, we have a basic problem here that will need serious attention.

The PA Volume Control (pavucontrol) utility is provided by a package of the same name. It is a graphical utility that allows a user to quickly configure PulseAudio for particular requirements (including adjusting source and sink levels, and profile selection) .

It can be installed with

zypper in pavucontrol

If you can’t get your microphone working at all, you will need to troubleshoot further. For that, I recommend following the advice given here
In particular, running the diagnostic script (as described in step #3), allowing it to upload the results to an online server, and sharing the link to it here for others to review and comment on.

installed pavucontrol, basically it just duplicates what we already have right buttoning the volume control that brings up ‘Audio volume settings’

checking Yast sound everything is as before, sound card 0 is dead, sound card 1 works, switching cards produces same result, sound card 0 is dead

I might add that of the two boxes we have, one has new Ryzen 7 innards and the other an older Intel i5 something, 4 core. commonality is the Asus motherboards. Before the Ryzen it was an AMD box too with the same problem.

We do have sound for most things, the video camera shows up as the output device, the camera works but the mike does not, at least not in Skype. Skype on our neighbour lady’s Ubuntu AMD box works just fine.

Following the howto instructions I get the following info that I am afraid we will have to leave to experts.

We do have sound after a reboot after the firmware update.

Setting either card as the primary card leads to no sound from that card. No sound from the primary card.

 	 	 	   Advanced Linux Sound Architecture Driver Version k4.4.103-36-default.

Sound Modules

0 snd_hda_intel
1 snd_hda_intel
2 snd_usb_audio

Sound Cards

HDA ATI HDMI at 0xfe960000 irq 58
1 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xfe800000 irq 59
2 [U0x46d0x825 ]: USB-Audio - USB Device 0x46d:0x825
USB Device 0x46d:0x825 at usb-0000:06:00.0-2, high speed

Your ALSA information is located at

Yes - I have same Skype bug - but if you set Skype to the ‘default’ mic, I find that works.

You may also have to set your USB mic as the ‘fall back’ input device in pavucontrol

Some sample menu selections](

Sometimes my USB mic is there in some - sometimes not. Select the ‘default’ if not there](

Again - note what I suggested wrt pavucontrol

Yes - but don’t give up. Let me know if my suggestion works.

As a further note to this thread, it is possible, with a specific pci assignment in the 50-sound.conf file, to swap the HDMI and analogue sound devices, such that a different one is consistently card-0 and the other card-1. If at anytime you are interested in doing such, let me know, and i can provide you the not-so-simple edit to the 50-sound.conf file that will make that so.

o.k., tried all the settings in skype for the mic but no go … nada.

either sound card can be assigned as 0 in yast, poking deeper is not my expertise, thank you

this is a perfectly stock 42.3, all updates so nothing is out of line due to my poking around

that we do not have a live mic is just symptomatic, the real problem is why neither sound card works when assigned as sound card 0 and that I believe we should leave to the good people at Nurnberg.

it’s almost Christmas so Merry Christmas to all of you out there … cheers till next year :slight_smile:

They are the experts and if you wish their attention , then the only way to be assured of that is to write a bug report.

Having stated that, your PC has HDMI as card-0. Apply this edit below in a /etc/modprobe.d/50-sound.conf file, replacing the code there, and it should reverse the two cards, putting the HDMI as card-1 and analog as card-0. Use root permissions to make / save the file, and reboot to test. To put things back the way they were afterward, simply remove the edits and reboot.

options snd_hda_intel index=0 vid=1022 pid=1457
options snd_hda_intel index=1 vid=1002 pid=aaf0

The diagnostic script that you ran gave me the information needed to deduce the above.

Same to you.

Note also - with the skype settings tuning, you also need to use pavucontrol, making the USB mic a backup mic in addition to a nominal selection.

edited file, reboot but no change, sound card 0 has no sound or volume menu

reset file as before

time for the Masters of Yast … yes ??

For certain the packagers of openSUSE LEAP know more.

This is very unusual. That 50-sound.conf file edit should have reversed the sound cards. You made no mention that happened - and provided us no feed back there. If that the case, then I can’t help but believe you did not implement that correctly, if the sound cards were not reversed. They should have been reversed.

Either that or think your PC has a bad install.

Good luck with your bug report.

also - what is your precise test that you use to assess if sound-card-0 is providing sound ?