No sound after upgrading from OpenSUSE 13.2 to Tumbleweed

Hi!I was running OpenSUSE 13.2 32 bit and have just upgraded to Tumbleweed 32 bit.Unfortunately there is no sound coming out whether I am playing a movie on VLC or streaming youtube videos.

Please assist.

More information needed.

  1. Do you have any working sound at all? For example: YaST > Hardware > Sound > Other > ‘Play Test Sound’
    If not, review the openSUSE Audio troubleshooting guide.

  2. Do you have the required multimedia support (from the Packman repo) installed?
    Multimedia Guide for openSUSE Tumbleweed - Multimedia - openSUSE Forums
    https://opensuse-community.org/

Test sound isnt playing when I run YaST > Hardware > Sound > Other > ‘Play Test Sound’

My sound configurations are as below

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k4.13.11-1-pae.

cat /proc/asound/modules

0 snd_hda_intel

cat /proc/asound/cards

0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xd4500000 irq 28

/sbin/lspci -nnk | grep -A2 VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
Subsystem: Hewlett-Packard Company Device [103c:1484]
Kernel driver in use: i915

I have the multimedia rpms from Packman installed but still no sound.

Please help

Review the sound troubleshooting guide I linked to in the previous post.

In particular, run the ALSA diagnostic script

sudo /usr/sbin/alsa-info.sh

Let it upload the report to an online server, and report back here with the URL that it provides so that others can review the output.

https://en.opensuse.org/SDB:Audio_troubleshooting#Script_to_run_to_obtain_detailed_information

Here is the output of
sudo /usr/sbin/alsa-info.sh at URL below
http://www.alsa-project.org/db/?f=a994dad5581d01603b820c37d6bfeb9be405aab1

Which output are you trying to listen to sound via? HDMI or speaker? I note that the speaker volume is down…


Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] -65.25dB] [on]
  Front Right: Playback 0 [0%] -65.25dB] [on]

I also suggest checking your PulseAudio configuration with the pavucontrol utility. Install it (package of the same name) if you haven’t done so already.

Issue is now fixed.

I went to PulseAudio Volume Control and in the Configuration tab I changed Built-In Audio to Analog Stereo Output and now I can get sound.

Thanks for all your help

Glad to have been of help :slight_smile: