No sound after upgrade to 13.1


after upgrading from 12.3 to 13.1 I can’t get any sound in KDE.

Steam sounds fine and I can get sound in Skype and Spotify if I disable Pulse Audio in Yast / Sound.

If I open Personal Settings / Sound & Multimedia / Sound System, I get the following error:

Unable to start the sound server to retrieve possible sound I/O methods.
Only automatic detection will be available.

Anyone knows what’s wrong?


I don’t know if it’s related. But I lost all sound after the update yesterday (It’s been a week since the last update, I also had to reinstall my ati driver to fix the black screen after the update yesterday).

In KDE settings, multimedia, the only way I can make my pc have sound is to change conncector from “analog output” to “speaker”.

Something’s broken after yesterday’s update??

What update?
There was no official update for 13.1 since Jan. 3rd…

Some packages on Packman were updated, but I doubt those would cause your problems. And they definitely didn’t cause your ati driver problem.

So, what repos are you using?

zypper lr -d

Check in YaST/zypper’s history (and Apper’s as well) which packages got installed and try to revert them if possible.
(“rpm -qa --last | less” will also give you a list of all installed packages sorted by the time they have been installed)

Your problem seems to be related to KDE’s phonon.
Which phonon packages do you have installed? Maybe not all got updated for some reason?

rpm -qa | grep phonon

This is the output from rpm -qa | grep phonon:


No newer version available according to Yast / Software Management

Also, sound in Windows running in VMware works fine.

Yeah, right. Everything except KDE apparently (i.e. everything not using Phonon).

Your packages seem to be ok.

Is VLC itself working?
Maybe that’s the cause (phonon-backend-vlc has a higher priority than gstreamer-backend-gstreamer-0_10).

PS: Maybe VLC is configured to use PulseAudio? (that could explain the “Unable to start the sound server” message when PulseAudio is disabled)
Check that in its settings, or try to remove/rename ~/.config/vlc/ (this will of course reset all VLC settings to their default).

Yes, VLC works and audio output is set to Automatic.

Do you know if Personal Settings’ failure is logged somewhere? Maybe that could give a clue.

Also, I tried setting VLC to use ALSA explicitly but that didn’t change anything. Personal Settings / Sound System still fails.

Also tried reactivating PulseAudio in Yast and then setting this as VLC’s explicit output. VLC still works but nothing else does with PA enabled.

OK, you can forget about the “Personal Settings” related stuff. After the upgrade, my start menu contained “Personal Settings” from KDE 3.5. No idea why but I used it when trying to get my sound started. I have now hidden it so I won’t do that mistake again. With “Configure Desktop” I could correct my messed up device list. My HDMI card, which is not connected to anything, had been set as the preferred device. Now I have sound in KDE.

No sound from Skype though, although it uses Pulse (the only option).

Ah, ok. So the “sound server” that could not be started was Arts…

That KDE3 “Personal Settings” (kcontrol) is part of the package “kdebase3”, you could uninstall it if you don’t need it anymore.
In earlier openSUSE versions, KDE3’s “Personal Settings” was explicitely hidden in KDE4’s menu by an openSUSE specific patch, but this was removed for 13.1.

No sound from Skype though, although it uses Pulse (the only option).

Didn’t you say in the first post Skype works when you disable PulseAudio?
Do you have PulseAudio enabled or disabled now?

I have reenabled PA since everything else works with it. Also found an article about pulse latency setting necessary for skype:

Now I get sound from skype but no sound into it. The mic seems fine but skype can’t hear me. Won’t be a problem if I call my dear mother but everybody else will wonder what’s wrong with me…

Found the last piece of the puzzle. My recording volume had been set to zero. With -25 db the sound is acceptable.

Apparently the sound settings had been f-ed up by the upgrade. Thanks for all help!rotfl!

Do you have pavucontrol (pulse audio volume control) installed to help configure pulse audio for your multimedia applications ? Apologies if you mentioned that already and I missed reading it.

Yes, it’s installed.