No Sound After Updates


I’m running opensuse 11.1 with KDE 4.1. I just did a fresh install today after getting fed up with the instability of both gnome and kde in Ubuntu. It crashed frequently. I haven’t had any problems with opensuse crashing, so even though it is a little harder for me to use I decided to try it out again.

Anyway, here is my problem. The Update Applet updated some stuff and now my sound doesn’t work (it was working before the updates). Now whenever I login to the desktop it says something about ALC663 analog not working and rolling back to the older setting or something. This apparently doesn’t work because there is still no sound.

For your information the sound card is some integrated piece of realtek but I’m not sure the exact part number.

Interesting. Restarting Alsa Sound seems to give me audio functionality…kind of. It removes the volume control from the taskbar and leaves the audio sounding bad, but at least it works. I have to do that every time I reboot now. The errors that were popping up have gone away, I have no idea how. I’ve just been screwing around in the /etc/modprobe.d/sound file.

One way to force an alsa restart after every boot is to put in the /etc/init.d/boot.local file (as a last line):
rcalsasound restart

There is an openSUSE troubleshooting guide here:
SDB:AudioTroubleshooting - openSUSE

There is guidance for updating alsa to work with the latest kernel here: Alsa-update - openSUSE One must read that carefully. An AMAZING number of users simply get the instructions wrong for updating, because they fail to read that page correctly.

BUT note a disadvantage of going down that path is often after every kernel update you will be forced to update your alsa, and sometimes it is a week or more before the latest precompiled alsa updates are available for the new kernel.

I’m also wrestling with alsa sound…

Following the Alsa-update - openSUSE instructions:

# zypper ar multimedia

# zypper install alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse

Loading repository data...                                                                    
Reading installed packages...                                                                 
No update candidate for 'alsa-utils'.                                                         
No update candidate for 'alsa-tools'.                                                         
No update candidate for 'alsa-firmware'.                                                      
No update candidate for 'alsa-oss'.                                                           
No update candidate for 'alsa-plugins'.                                                       
Resolving package dependencies...                                                             
Nothing to do.

After more digging, seems these required packages are missing…

# zypper se --details -r multimedia
Loading repository data...
Reading installed packages...

S | Name             | Type       | Version       | Arch   | Repository
  |          | package    | | i586   | multimedia
  |          | srcpackage | | noarch | multimedia
  | aldrin           | package    | 0.11-2.18     | noarch | multimedia
  | aldrin           | srcpackage | 0.11-2.18     | noarch | multimedia
  | cuetools         | package    | 1.3.1-1.4     | i586   | multimedia
  | cuetools         | srcpackage | 1.3.1-1.4     | noarch | multimedia
  | jost             | package    | 0.4.6-1.23    | i586   | multimedia
  | jost             | srcpackage | 0.4.6-1.23    | noarch | multimedia
i | librasqal-devel  | package    | 0.9.16-29.1   | i586   | multimedia
i | librasqal1       | package    | 0.9.16-29.1   | i586   | multimedia
i | libredland-devel | package    | 1.0.8-4.3     | i586   | multimedia
i | libredland0      | package    | 1.0.8-4.3     | i586   | multimedia
i | libwavpack1      | package    | 4.50.1-2.4    | i586   | multimedia
  | libzzub          | srcpackage | 0.2.3-5.21    | noarch | multimedia
  | libzzub-devel    | package    | 0.2.3-5.21    | i586   | multimedia
  | libzzub-plugins  | package    | 0.2.3-5.21    | i586   | multimedia
  | libzzub0         | package    | 0.2.3-5.21    | i586   | multimedia
  | rasqal           | package    | 0.9.16-29.1   | i586   | multimedia
  | rasqal           | srcpackage | 0.9.16-29.1   | noarch | multimedia
i | redland          | package    | 1.0.8-4.3     | i586   | multimedia
  | redland          | srcpackage | 1.0.8-4.3     | noarch | multimedia
  | schism           | package    | | i586   | multimedia
  | schism           | srcpackage | | noarch | multimedia
  | tuxguitar        | package    | 1.1-4.12      | i586   | multimedia
  | tuxguitar        | srcpackage | 1.1-4.12      | noarch | multimedia
  | wavpack          | package    | 4.50.1-2.4    | i586   | multimedia
  | wavpack          | srcpackage | 4.50.1-2.4    | noarch | multimedia
  | wavpack-devel    | package    | 4.50.1-2.4    | i586   | multimedia

I am no zypper guru, but this seems to confirm that observation:

# zypper update -r multimedia alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins
Loading repository data...
Reading installed packages...
No update candidate for 'alsa-utils'.
No update candidate for 'alsa-tools'.
No update candidate for 'alsa-firmware'.
No update candidate for 'alsa-oss'.
No update candidate for 'alsa-plugins'.
Resolving package dependencies...
Nothing to do.

I have previously updated from the openSUSE update site and KDE 42, which seem to give me the following sound packages - seems strange that the version numbers are all over the place…

# rpm -qa | egrep '(alsa|libasound|pulse|gstream)'

Any suggestions?

Likely you have them installed already, or you have the arbitrary name “multimedia” preassigned.

Why so many updates from a multimedia repository. The rpms on the multimedia repository (if its the same repository from the troubleshooting guide) are all cutting edge and SHOULD NOT BE INSTALLED unless you have no other choice IMHO. One should ask FIRST before installing such rpms, to try and get a flavour if they will make the situation worse.

Also, don’t forget to run the “zypper rr multimedia” to remove the repository after installation of any rpms from such a repos. If you do not do that you are NOT correctly following the guide you quote, although clearly the guide does NOT say to install such rpms.

KDE-4.2 ? … hmmm … openSUSE-11.1 comes with 4.1.3. Updating one’s KDE to a version such as 4.2 or 4.3 can have unexpected effects. I refuse to do that for my own PCs because I can not be bothered with the pain of sorting such issues, and accordingly I won’t waste my time with PCs of others who update their KDE.

So apologies, but if you are on KDE-4.2, then someone else will need to help you.

BUT before I leave this thread (which I will do after this post) I note this:

You should not have 3 alsa-driver-kmp installed. That is practically GUARANTEED to ensure NO SOUND.

I don’t think you will like all of my suggestions … so please don’t take them personal, … its just my very very conservative view of what I follow that has kept my Linux distributions functioning well for years

My suggestions are:

  • remove 2 of the 3 alsa-driver-kmp default versions, keeping ONLY the one specific to your kernel version. That is the guidance in the alsa-update URL that you quote, which you clearly did NOT follow correctly
  • don’t update your PC from repositories that you do not know about and to which you can not point to a specific guide or clear reference.
  • If an openSUSE desktop (such as 4.1.3) does not do what you want, then either try gnome or KDE3, or try another distribution … unless of course, you wish to explore and test cutting edge stuff. BUT if you wish to test cutting edge, you need to carefully follow guidance when given, and installing 3 alsa-driver-kmp … is not following guidance.

Apologies again for my harsh views on this. And the BEST of GOOD WISHES in your efforts to sort this. But note I do NOT install updated KDE versions because I do not know enough myself about the hiccups from such cutting edge updates, … and so it surprises me so many others are willing to take such updates on … Good on 'em for trying, but IMHO what you have encountered is what can happen.

Again, Good Luck, and I’ll now bow out of this KDE-4.2 thread.

Appreciate the feedback oldcpu - will remove the multiple alsa kernel modules though I do use them from time to time :slight_smile:

Hey guys,i am new to linux.I was having the same problem with my sound(no sound after update,opensuse 11.1).
But one thing worked.I went to Yast>Software>Software Management and typed alsa.What ever showed to be installed i marked them for an update.I put in the DvD,i was connected to the net too.Then i accepted.
Now sound works fine.
Best of luck.