No printer drivers in YaST

I have 20+ PCs running 13.1 and all configured much the same way. All have various network printers.
I just tried adding a new printer and most configured without issues, print driver being ‘raw queue’.
In the case of five of them, they fail to install the new printer as they seem not to have any printer drivers when I try to search for ‘raw queue’ in YaST. (If I search for any model, same problem, no print drivers). A good, working PC, displays ‘Determining matching printer drivers…’ when I attempt to search for drivers, but the five problem PC’s seem not to make any attempt at searching for drivers and the ‘Determining matching printer drivers…’ message fails to display.
The raw queue was there previously, as I have several printers already set up on these PC’s, in the same manner.
I know that there were issues with some new installations, where printer drivers were missing, but I cannot recall or locate the solution that rectified the problem, I seem to think there was a file issue, possibly in etc/cups?
Can anyone assist, please?

Most of the drivers you need are already installed other than HP for which you need to install hplip. Do you have the Printing repo enabled I get quite a lot of packages if I simply search for ‘printer.’

I have sometimes found that using the CUPS printer install options takes you to a printer driver menu where you can find alternative drivers for the same machine, one of which will work better than another.

Yes, I recall a previous thread mentioning this behaviour. (I had a vague recollection that an error can occur during package installation whereby drivers are not unpacked properly or similar.)

Anyway, there is an openSUSE bug describing similar…

and only impacts a few under certain conditions. The workaround as described by Johannes Meixner

The current workaround is to retry “lpinfo -m” (as root)
until it actually shows printer driver descriptions.

Then also YaST will show the printer driver descriptions.

Hope that helps.

deano, your suggestion worked, thank you. Most worked on first attempt, one took several “lpinfo -m” attempts before the printer drivers displayed.

Great result - good to hear! :slight_smile: