No plymouth boot splash on startup

I have a Lenovo laptop with nVidia and Intel Haswell graphics chips. The BIOS supports both Optimus and UMA only modes. If I boot with Intel Graphics, i.e. UMA only mode, in place of Plymouth boot splash, I get a blank screen, after which GDM starts. If I use the optimus mode, the Graphical boot splashes like the openSUSE default bootsplash do not work, but text based themes like tribar etc still work.

I believe it has something to do with the framebuffer driver for intel (i915) not being loaded in case of UMA mode and graphical mode not properly initializing in case of Optimus mode (nouveau).

Anyways, I have tried almost everything discussed on the internet including the /etc/sysconfig/kernel configuration parameter but nothing has worked so far. I want to use the laptop in Intel only mode, can anybody here help me to make plymouth work properly. It works properly on the same laptop under other systems like Fedora and Debian, in both modes.

Oh, and I am on latest snapshot of tumbleweed, i.e. 20160226.

I too have noticed absence of Plymouth boot splash under Tumbleweed, I suspect this is intentional as SSDs boot so fast these days.

I doubt that it is intentional.

Plymouth is not only needed/used for the bootsplash, but also for displaying a graphical password prompt for encryped partitions.
And that’s currently broken too.

According to https://bugzilla.suse.com/show_bug.cgi?id=966255#c23, the reason might be that plymouth starts too early during the boot process and fails therefore.

Although if your system boots too fast, you might not see the bootsplash at all, because it slowly fades in from black… :wink:

I cannot help with the original problem though.
Just two suggestions:

  • Is the intel kernel module in the initrd? You can check with “lsinitrd”.
    This might not be the case when you used the nvidia chip or “nomodeset” when the initrd was created.

  • Maybe changing grub2’s settings in /etc/default/grub might help (run “grub2-mkconfig -o /boot/grub2/grub.cfg” to “apply” the changes), GRUB_TERMINAL and GRUB_GFXPAYLOAD_LINUX in particular.
    See https://www.gnu.org/software/grub/manual/html_node/Simple-configuration.html for an explanation of those options.

I see the same with default installation of XFCE pattern in QEMU. I have bootsplash in 13.2 and Leap VMs with identical settings (qemu invocation).

Same here. I find plymouth comes and goes with Tumbleweed.

Got the same setup as the OP (i915 and nouveau optimus) and it isn’t working here. Not tried too much yet but a bit wary of rocking the boat. Already been booted just to terminal (setting ‘nomodeset’ did that; promptly unset).

Any insight / good suggestions would be nice. There has to be a clear difference between what OpenSUSE is doing and Fedora etc.

Same problem. Still. And its intermittent?! Why can’t this bug be zapped on a rolling release distro?? Thanks.

Hi and welcome to the forum :slight_smile:
What sort of graphics card do you have? Not hybrid?

To be honest, my systems have SSD’s I just remove the packages, lock them and rebuild initrd… knocks a second or so off boot time…

Thanks for the welcome. Think I have 2 “cards”? From “/usr/sbin/hwinfo --gfxcard”:


08: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.366]
  Unique ID: _Znp.YnzOCluPhb6
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel Mobile 4 Series Chipset Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2a42 "Mobile 4 Series Chipset Integrated Graphics Controller"
  SubVendor: pci 0x104d "Sony Corporation"
  SubDevice: pci 0x9025 
  Revision: 0x07
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xe8400000-0xe87fffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  I/O Ports: 0x8130-0x8137 (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 29 (12443 events)
  Module Alias: "pci:v00008086d00002A42sv0000104Dsd00009025bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown


26: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.366]
  Unique ID: VCu0.ZjUFH5GJEdE
  Parent ID: vSkL.8gSEJ6UgIH7
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia G98M [GeForce 9300M GS]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x06e5 "G98M [GeForce 9300M GS]"
  SubVendor: pci 0x104d "Sony Corporation"
  SubDevice: pci 0x9025 
  Revision: 0xa1
  Memory Range: 0xe4000000-0xe4ffffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  Memory Range: 0xe2000000-0xe3ffffff (rw,non-prefetchable)
  I/O Ports: 0x7000-0x707f (rw)
  IRQ: 30 (no events)
  Module Alias: "pci:v000010DEd000006E5sv0000104Dsd00009025bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #7 (PCI bridge)


Primary display adapter: #8

Abandoned the proprietaryy nvidia driver and am using nouveau.

Is this a hybrid? Stamina/Speed switch?

Hi
Yes, that looks like a hybrid setup, which may be the issue. Have you looked at using bumblebee?

I don’t have this setup, so can’t really help :frowning:

Thanks. I don’t think I’ve got the Optimus setup for Bumblebee. Mine’s a switch. Here it is:

http://www.nvidia.com/object/sony_VAIO_z.html

Because someone who experiences it needs to debug it and come up with root cause.

Hi
Ahh, then I would guess it can’t figure out which one it’s set to use. Is there a BIOS option to set the GPU and ignore the switch?

Else, I’m thinking in your case it may be bug report time…?

Maybe other forum users have some ideas.

Fair enough. I got the impression it was fairly common because it’s has been raised in a number of posts going back a couple of years. It’s beyond my technical ability. That’s all…

Very occasionally I see the splash screen and recently I sometimes see it when I close down. I just put it down to the rolling nature of tumbleweed.

Still nobody so far provided recipe how to reproduce it. It does not happen on installation I have …

It happens, maybe 30% of the time here, with Intel video.

There does not appear to be a common theme to the issue either. My current p/c has a nvidia graphic card and it is the same with the built in driver or the nvidia driver. My other p/c has an ATI card and that is the same.