No more updates?

When using Gonome, I used to get updates (usually security ones) every day. Since switching to KDE4 nearly a week ago, I haven’t had any. The Updates repository is enabled. Can’t believe KDE4 is that secure :slight_smile:

Only security fixes for KDE come through the update server. In Gnome you probably had the Gnome repo enabled. Add the KDE4:42 repo and you will not only receive updates, you will get KDE4 4.2.4 (at this moment) which is a enormous step forward compared to 4.1.3 which was the same for 4.0

Post result of

zypper lr --details

Knurpht: I’m already running 4.2.4

hgm@linux-3y62:~> zypper lr --details
# | Alias                 | Name                                  | Enabled | Refresh | Priority | Type   | URI                                                                     | Service
1 | KDE:42                | KDE:42                                | Yes     | Yes     |   99     | rpm-md |        |
2 | openSUSE-11.1-Updates | openSUSE-11.1-Updates                 | Yes     | Yes     |   99     | rpm-md |                                |
3 | repo-non-oss          | openSUSE-11.1-Non-Oss                 | Yes     | Yes     |  120     | yast2  |            |
4 | repo-oss              | openSUSE-11.1-Oss                     | Yes     | Yes     |  120     | yast2  |                |
5 | repo-update           | openSUSE-11.1-Update                  | Yes     | Yes     |   99     | rpm-md |                               |
6 | repo_15               | openSUSE BuildService - Mozilla       | Yes     | Yes     |   99     | rpm-md |        |
7 | repo_21               | Packman Repository                    | Yes     | Yes     |   99     | rpm-md |                             |
8 | repo_6                | openSUSE BuildService - KDE:Community | Yes     | Yes     |   99     | rpm-md | |

That looks good. Now type in su terminal

zypper ref


zypper lu

post result for lu

linux-3y62:/home/hgm # zypper lu
Loading repository data...
Reading installed packages...
S | Repository                      | Name                         | Version                   | Arch
v | openSUSE BuildService - Mozilla | MozillaThunderbird           |              | i586
v | openSUSE BuildService - Mozilla | MozillaThunderbird-lightning | 0.9-3.7                   | i586
v | Packman Repository              | Vuze                         |          | noarch
v | Packman Repository              | Vuze-libswt3-gtk2            | | i586
v | Packman Repository              | backintime                   |           | noarch
v | Packman Repository              | backintime-gnome             |           | noarch
v | openSUSE-11.1-Updates           | desktop-translations         | 11.1-6.4.1                | noarch
v | openSUSE-11.1-Updates           | dos2unix                     | 3.1-437.37.1              | i586
v | Packman Repository              | ffmpeg                       |                | i686
v | Packman Repository              | libavcodec52                 |                | i686
v | Packman Repository              | libavdevice52                |                | i686
v | Packman Repository              | libavformat52                |                | i686
v | Packman Repository              | libavutil49                  |                | i686
v | Packman Repository              | libgstphotography-0_10-0     |           | i586
v | Packman Repository              | libmodplug0                  |              | i586
v | Packman Repository              | libpostproc51                |                | i686
v | Packman Repository              | libswscale0                  |                | i686
v | Packman Repository              | libx264-67                   |     | i686
v | Packman Repository              | libxine1                     |           | i686
v | Packman Repository              | libxine1-codecs              |           | i686
v | Packman Repository              | libxvidcore4                 |              | i586
v | openSUSE BuildService - Mozilla | mozilla-nspr                 | 4.8-1.1                   | i586
v | openSUSE-11.1-Updates           | mozilla-xulrunner181         |              | i586
linux-3y62:/home/hgm #

So there are updates there
What happens when you do

zypper ref
zypper up

in a su terminal

What happens is that I get a lot of updates -)
So why don’t they arrive automagically? I’ve just checked the Online Update Configuration in YaST, but there’s no update repository listed in there. Went through the registration process (again!) and it says my repos don’t need adding to…
Also noticed that I have two update repos in Software Management (see output in earlier message): which is the correct one?

I never use automatic updates, I always remove the updater applet… Just delete one of the Update repos from your list. They are both the same.

Run Yast - Online Update, once a week

Any particular reason for that? I mean I can see that it’s not rocket science to fire up the terminal and run the occasional “zypper up” (is “zypper ref” before that necessary?) but it’s also quite nice to get it automatically…

zypper ref
refreshes them, so yes do this first.

So long as your repos are as you list them earlier, using the applet should work.
You do not need to go to Yast - Online Update Config!

Check the settings in the applet with right click, that the necessary check boxes are marked as you require.

I don’t use it mostly because I’m running development packages. But I wouldn’t use it even if I just had a standard install. I don’t like it. It’s not intelligent enough.

It does seem a bit dumb: got it to work by right-clicking and disabling the various options relating to “chargers” and “low load”.

Once again, thanks for your help!

Don’t use it either. For same reason as caf.

Great minds think alike;)

I just go into Yast -> Software Management, which works well for me. It will list Available new packages as well as Upgrades to existing.

I’ve been following this thread to see if it leads me to a solution for this problem:

Repository ‘Main Update Repository’ is up to date.
Building repository ‘Main Update Repository’ cache [done]
Error building the cache:
‘’ ‘-o’ ‘/var/cache/zypp/solv/repo_3/solv’ ‘/var/cache/zypp/raw/repo_3’

gzip: deltainfo.xml.gz: invalid compressed data–format violated
repo_updateinfoxml: not well-formed (invalid token) at line 3798:155

Skipping repository ‘Main Update Repository’ because of the above error.
Some of the repositories have not been refreshed because of an error.

It occasionally disappears. But sometimes I cannot use that repo for days or even weeks. Is there a problem in the repo or on my machine? I also get a “digest verification error” associated with deltainfo.xml.gz which I tell zypper to ignore or the entire zypper up stops.

Have you tried removing the repo altogether?

Try adding one back in - maybe use a mirror from here:
openSUSE Download Mirrors - Overview

If that doesn’t solve it - Clear out temp files and unnecessary cached data

I have tried removing and re-adding. I’ll do again with one from the mirror list.

The issue of clearing temp files has me puzzled. On the surface, I would think I could empty the whole /tmp directory, but my paranoia prevents me. Are you suggesting I empty /tmp or is there another temp file to look for?

Still I would not worry as much, during the first few weeks of a fresh install you gt lots lof updates but over time it becomes minimal.
It happens on all distros.