No Mail From Cron In 11.1


When I run cronjobs, I don’t receive an email despite having one sent to me from the cronjob. I can look in mailq and see this output:

-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
16FD42C2FA 587 Thu Dec 17 00:30:01
(connect to[]:25: Connection timed out)

58FFE2C2C1 581 Tue Dec 15 00:00:01
(connect to[]:25: Connection timed out)

C33AA2C305 576 Fri Dec 18 00:30:01
(connect to[]:25: Connection timed out)

A2C0E2C304 575 Fri Dec 18 00:00:01
(connect to[]:25: Connection timed out)

709602C2E0 583 Tue Dec 15 00:30:01
(connect to[]:25: Connection timed out)

F26572C2F9 585 Thu Dec 17 00:00:01
(connect to[]:25: Connection timed out)

– 4 Kbytes in 6 Requests.

I have looked in some other posts and see similar questions, but I need very specific instructions on how to fix this. Could someone please help me out?


Probably because your ISP blocks customer computers from sending out mail directly on port 25 because infected machines send out spam. You have to relay through your ISP’s relayhost. When you find out what it is, you can set it in the postfix config, restart postfix and you can mail out.

Perfect, I will do that. Errrr, where do I get that :slight_smile:

Get what, the relayhost? Ask your ISP. It’s usually the mail server that they ask you do connect to to fetch and send your mail.

Is that not the relay host that I have listed in my output from mailq? I am on hold with my ISP now, but thought I would check on that while waiting.

Okay, mail servers are “”. Where do I place this in postfix? Please point me in the right direction with detail where possible.


Well I only use the CLI, not YaST to configure postfix, so if you are not scared of using a text editor…

as root of course, edit /etc/sysconfig/postfix and set RELAYHOST.
SuSEconfig --module postfix
rcpostfix reload

I’m sure you can do this in YaST, but I never bothered to find out how, it was always faster for me this way, and doesn’t break YaST configuration either. This assumes you have not modified yourself.

Outstanding! Problem solved. Thanks for all the help.:slight_smile: