No keyboard backlit on kernel 4.18

I have fresh install of TW. As mentioned in title I don’t keyboard backlight in my Asus UX410UA. Before that I had installed TW with 4.17 kernel ant there was everything ok. When I press Fn+F3/F4 I can see CSD frame but no light. The same in Gnome panel, only screen and volume bars are present.

Hi, at times adding the option "acpi_osi= " (including the trailing blank) or acpi_osi=Linux to the kernel command line helps with such problems on some ASUS laptops.

I tried it already and it didn’t work.

It works on Manjaro and Fedora with kernel 4.18.

I can confirm your findings with kernel 4.18.5: the “acpi_osi=Linux” that is working on Leap 15.0 is not working in a TW KDE LiveDVD.
Possibly a regression in the asus_wmi module, but that is really beyond my pay grade :frowning:
Consider opening a bug report about that: openSUSE:Submitting bug reports - openSUSE Wiki

Kernel 4.18.7 from kernel:stable repo with “acpi_osi=Linux” works here on Leap 15. Cannot check with TW at the moment, but it doesn’t seem a kernel bug (anymore?).

bruno@LT_B:~> uname -r
bruno@LT_B:~> dmesg |grep 'Command '
    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.18.7-1.g952d850-default <snip> acpi_osi=Linux splash=silent quiet showopts

on my notebook, an asus G750J it does also not work any more.

i already use Kernel 4.18.7 from kernel:stable repo with “acpi_osi=Linux” :
dmesg |grep 'Command ’
0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.18.7-1.g952d850-default root=UUID=54f5b264-0453-472c-b92e-697272ee49c1 nomodeset enable_mtrr_cleanup pcie_aspm=force clocksource=acpi_pm acpi_osi=Linux zswap.enabled=1 elevator=deadline nopti nospectre_v2 quiet showopts

and i already use the “acpi_osi=Linux” option at least since 2016.

Two relevant bug reports currently open:

As a test or workaround you might try the following:

bruno@LT_B:~> su -
LT_B:~ # cd /sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight
LT_B:/sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight # cat brightness
LT_B:/sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight # echo 3 >> brightness
LT_B:/sys/devices/platform/asus-nb-wmi/leds/asus::kbd_backlight # echo 0 >> brightness

Not necessarily a kernel problem, see comment #27 here

FWIW: From the MLs and this posts it looks like it’s an ASUS only problem.

Just fired up TW 20180911 Gnome with kernel 4.18.7-1, both Fn+F3 and Fn+F4 are apparently mapped to “kbd-backlight=0”, that OSD icon shows up but apparently no effect at system level.
“echo (0,1,2,3) >> brightness” works but there is no apparent connection between that variable and keyboard input. “acpi_osi= <whatever>” seems to have no effect.
So doesn’t seem a kernel problem (4.18.7-1 works OK on Leap 15) nor much related to the DE (both KDE and Gnome don’t work correctly here).

According to the problem was a regression in upower 0.99.8 and should be fixed in upower 0.99.9 already available as an “Experimental package”.

Feature should be fixed again starting from TW 20181107:

==== upower ==== Subpackages: libupower-glib3 typelib-1_0-UpowerGlib-1_0 upower-lang

- Add upower-fix-keyboard-backlight.patch: daemon: Fix upower's
  keyboard backlight support. Disabling kernel tunables blocked us
  from accessing /sys, meaning we couldn't change keyboard
  backlight levels.

thanks OrsoBruno

i can confirm it is working again.