No IPv4 address in LXD containers

I have performed a fresh network install of Tumbleweed 32bit (text mode) and installed LXD and initiated it. I’ve accepted all the defaults, and only changed storage pool to dir. When launching containers, I am getting an IPv6 address using default bridge lxdbr0, but no IPv4. I’ve disabled the firewall and launched a Debian container. This is getting an IPv4 address now, but if I launch a Tumbleweed container - this is still not working. There seems to be some issue with networking going on, any advice will be much appreciated. Thank you.

Try disabling firewall as well as Apparmor:

systemctl disable --now apparmor.service
systemctl disable --now firewalld.service

Then restart your system. These steps helped me to solve such problem.