No Internet Connection

Using KDE desktop on laptop.

I am having trouble diagnosing an internet connection problem.
By way of background I have been using my laptop to set up six wifi aps, all of which have both frequencies and are offering multiple SSIDs two thirds of which are hidden. This has resulted in more than usual network activity on my part and at some stage in the process a new problem has arisen. To try and understand what is going on I have turned off the wireless NIC and am working with copper. This is only a problem for the two laptops I have been using. The main machine is a modern Lenovo running Tumbleweed, the other an ancient IBMT42 32 bit running Antix 19. I am raising this question now with respect to the Lenovo but the problem seems to relate to DHCP not working correctly on these devices.

In short, my NIC with a fixed IP, connects to the switch and I can ping the route ip but I get a warning exclamation mark on the task bar network widget and cannot get a WAN connection.
This is true on my usual subnet and also if I set the NIC for DHCP.

If I set the NIC for dhcp and connect to a different subnet the connection works fine and can connect to the WAN.

My desktop machines are all connected to the same switch with the same usual subnet and are all working as required.

What am I missing please?

I am not completley understanding what you are explaining and you show not facts. Thus the following general way of debugging:

You check from bottom to top:

  1. Is the NIC up with an IP address?
ip addr
  1. Can you connect to another system on your LAN?
ping -c1 <IP-address of your router>

(I hope you know that address)

  1. Do you have a default route to the Internet?
ip route
  1. Can you connect to a system on the internet?
ping -c1
  1. Can you resolve host/domain names?
ping -c1

Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.

So start with 1. and do not hesitate to post the output here to get help on the interpretation.

Hi Henk and many thanks for your reply. I cleared all of the hurdles except the last when I had message:-

Name or Service not known

Sorry I cannot cut and paste but on the problem machine I have no connection.
Seems there is no name service so I must have poor configuration. Please can you advise how I should resolve as my router is supposed to have ISP DNS is supposed to be running.

Do I understand correct that steps 1 - 4 are passed correctly and that things fail at step 5?

When that is the case, you will probably admit that you have connection to the internet and that thus the thread title is a “jump to conclusions” instead of a fact. :wink:

Let us check your DNS resolver configuration:

ls -l /etc/resolv.conf
cat /etc/resolv.conf

Yes, all steps except the last worked as expected. I agree I have a connection but cannot ping the website you advised. Still no connection on laptop so will type results here in abbreviated form:-

ls -l /etc/resolvconf
interface order
run-> /run/resolvconf

cat /etc/resolv.conf
No such file or directory

Looks like we are getting somewhere. If you want more detail I can type more but am sending this now.

It’s a conf file, you missed the period :wink:

ls -l /etc/resolv.conf
lrwxrwxrwx 1 root root 26 Sep 15  2019 /etc/resolv.conf -> /run/netconfig/resolv.conf

I have put in the symlink that was missing and I think I am there with the lan connection.
Will report back again when I start on wifi.
Many thanks for the pointer!