No internet connection

Hi guys. First my specs. I am currently running a Leap 15 with Gnome on HP Probook 6550b. I’ve recently upgraded my internet to fibre internet. The odd thing that is going on at the moment is that none of my browsers will open up a page. I’ve tried Epiphany, Chrome and Firefox. All say some sort of “No IP address” error. In the background as well the MEGAsync is syncing happily away. Transmission is continuing to download with speed. But I cannot do a Zypper upgrade either.

Now, I am currently typing all of this on my daughters laptop which is running 42.3 on a Dell Latitude E43000. Chromium works fine on hers as does Epiphany.

So all in all I am a bit puzzled and could do with some gentle help from you fine folks.

Bittorent typically does not use name resolution.
It’s possible MEGAsync may not either.
But, typically everywhere you try to go using a web browser typically does.

Try running the following, if you’re subject to a fairly well known bug, this should fix the problem. No need to reboot, just close your browser and re-open.

netconfig -f update


Thank you. That did it.

Today I had a similar problem with a laptop running leap15.0, which for the first time had no connectivity via wifi.
Your command solved the problem.
Thanks a lot for the fix, although I had no idea what caused the problem.

If you notice sluggish transfer speeds and you need to download important files faster, you can increase the download speed by configuring the software to fully utilize your Internet bandwidth.