no inbuild micro on xps 1530

Hi,

i’ve just installed opensuse 11.2 (Gnome) on my Dell xps1530 and everything works well, i’m very happy BUT inbuild microphone doesn’t want to work! It’s the only bug,not so bad ;-)) but i need it…

Here’s my infos:
alsa-info.sh

rpm -qa ‘alsa’:
alsa-oss-1.0.17-25.2.x86_64
alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
alsa-1.0.21-3.2.x86_64
alsa-plugins-1.0.21-3.3.x86_64
alsa-utils-1.0.21-3.1.x86_64
alsa-plugins-32bit-1.0.21-3.3.x86_64
alsa-oss-32bit-1.0.17-25.2.x86_64
alsa-plugins-pulse-1.0.21-3.3.x86_64
alsa-devel-1.0.21-3.2.x86_64

rpm -qa ‘pulse’:
pulseaudio-0.9.19-2.3.x86_64
libpulse0-0.9.19-2.3.x86_64
libpulse-browse0-0.9.19-2.3.x86_64
pulseaudio-module-zeroconf-0.9.19-2.3.x86_64
libpulse-mainloop-glib0-0.9.19-2.3.x86_64
libpulse0-32bit-0.9.19-2.3.x86_64
alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
pulseaudio-module-bluetooth-0.9.19-2.3.x86_64
vlc-aout-pulse-1.0.3-2.2.x86_64
pulseaudio-module-x11-0.9.19-2.3.x86_64
alsa-plugins-pulse-1.0.21-3.3.x86_64
pulseaudio-module-lirc-0.9.19-2.3.x86_64
pulseaudio-utils-0.9.19-2.3.x86_64
pulseaudio-module-gconf-0.9.19-2.3.x86_64

rpm -q libasound2
libasound2-1.0.21-3.2.x86_64

uname -a
2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/50-sound.conf
options snd slots=snd-hda-intel

u1Nb._3vRJ7r6oP9:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Thank’s for your help.

up!

nobody to help me and my dell xps1530 microphone ?

Regards

Your title "no inbuild micro on xps 1530 " is NOT going to get you the attention you want. Its REALLY bad, and not descriptive at all. Users who specialize in sound will NOT think “micro” is a “microphone”. Rather they think “micro” is a “microcomputer”.

I know that I for one saw the title and deliberately ignored the thread. My view as that I have no idea as to what an “inbuild micro” is. I do know what an “integrated microphone” is.

I have social comitments tonight so I can not provide suggestions tonight.

I’ll try to look at this tomorrow 9-Dec.

Hi,

I’m back from my social commitments. I took a look at the mixer settings documented in that script, and there are some settings I do not understand. Note that getting an internal mic to work can be difficult (as it may be a digital as opposed to analog, and you need to figure out which). Reference your mixer, please note:

ARECORD
**** List of CAPTURE Hardware Devices ****
**card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx A[/b]nalog]
**!!Amixer output
**!!-------------

!!-------Mixer controls for card 0 [Intel]
**Card hw:0 ‘Intel’/‘HDA Intel at 0xf6ffc000 irq 21’
** Mixer name : ‘SigmaTel STAC9228’
**Simple mixer control ‘Front Mic Jack Mode’,0
** Items: ‘Mic In’ ‘Line In’
Item0: ‘Mic In’
**Simple mixer control ‘IEC958’,0
** Mono: Playback [off]
Simple mixer control ‘IEC958 Playback Source’,0
Items: ‘Digital Playback’ ‘ADAT’ ‘Analog Mux 1’ ‘Analog Mux 2’ ‘Analog Mux 3’
Item0: ‘Digital Playback’
**Simple mixer control ‘Capture’,0
** Front Left: Capture 14 [100%] [21.00dB] [on]
Front Right: Capture 14 [100%] [21.00dB] [on]
Simple mixer control ‘Capture’,1
Front Left: Capture 0 **[0%] **[0.00dB] [off]
Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control ‘Capture’,2
Front Left: Capture 0 [0%] [0.00dB] [off]
Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control ‘Input Source’,0
Items: ‘Mic’ ‘Front Mic’ 'Digital Mic’
Item0: 'Mic’
Simple mixer control ‘Input Source’,1
Items: ‘Mic’ ‘Front Mic’ 'Digital Mic’
Item0: 'Mic’
Simple mixer control ‘Input Source’,2
Items: ‘Mic’ ‘Front Mic’ 'Digital Mic’
Item0: 'Mic’
Simple mixer control ‘Mux’,0
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control ‘Mux’,1
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control ‘Mux’,2
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]

When I look at the above I see you have “input source 0” set to “mic” (ie an external mic) and “capture 0” ON. But you have Mux0 at 0%.

No where in input source 0, nor input source 1, nor in input source 2, do I see digital mic selected. Its quite possible your internal mic is a digital mic.

IMHO you need to tune your mixer settings.

In kde that is typically done with kmix. I speculate in gnome its done with alsamixer or amixer.**

thanks for the lesson but as you must see, english is not my native language so…

Thanks for your help, i’m going to check alsamixer.
As you think, the integrated microphone is digital.