No hdmi out on asus computer

No hdmi output while connecting to :
a) TV ( on hdmi port )
b) laptop ( with hdmi to usb converter – (hdmi video capture))

first laptop is ASUS g731gv withNVIDIA TU106M – RTX2060 mobile plus Intel UHD 630 (driver i915)
nvidia driver nouveau

second laptop is ASUS g75vw with NVIDIA GF114M – GeForce GTX 670M
driver nouveau

following is output of command echo “xrandr -q”, “xrandr --listproviders”, “xrandr --listmonitors”, “zypper se xf86”, “lsmod | grep nouveau”, “lspci -nnk | grep -i -E ‘VGA|3D|Display’ -A 5”, "lspci -nnk | grep -i -E ‘VGA|3D’ -A 3"“cat /proc/acpi/bbswitch”, “inxi -Gxxx” as normal user, and using sudo.

g755vw : normal : [openSUSE Paste]

g755vw : sudo : [openSUSE Paste]

g731gv : normal : [openSUSE Paste]

g731gv : sudo : [openSUSE Paste]

I can’t say if it was working with leap 15.4 or 15.3

But to day it is working with window 10 without any special installation.

Any help is welcome.

May be I’m wrong, but I guess “hdmi video capture” is to have an hdmi->computer link, not a computer->monitor one


Did you notice the Perl errors raised by “inxi”?

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:

And, when you attempt to attach a HDMI device, does the systemd Journal indicate any related errors?

  • You may well have more than a few system installation issues …

No .
You put any hdmi output to the converter hdmi input, and the usb 3.0 output of the converter to the usb 3.0 computer input.

I found where my problem come from.
On opensuse leap 15.4, you must first make all the connections. Then power on the computer which receive the hdmi signal then power up the computer which send the hdmi signal.
You can also logout then login the computer which receive the hdmi signal.
It seems that the hdmi port which send the signal must found a device connected to the port before activing it.

On windows 10, you can start your browser, connect to netflix, start the film, then connect the hdmi cable to the monitor.
With leap you must at least logout, then login.

That is my conclusion from the test I have done these days.

Any comment is welcome.