No HDMI Audio 13th Gen Intel Framework Laptop

I have been digging for a while now to find a solution on many forums but I just don’t seem to have found anything that has delivered a solution. I have a 13 generation Intel Framework laptop that I have put openSUSE Tumbleweed as my choice. It has been a great fit, except for the lack of sound coming from HDMI. Dock stations with dedicated audio devices do show up and are available.

Since HDMI Audio works well with my older HDMI capable machines, Dells and HPs alike, I am thinking this is an issue with either the 13th Generation chipset or something specifically wrong with the Framework. I have not tried any other operating systems on the Framework to compare but I am not particularly interested in anything other than Tumbleweed with Plasma.

Here is my post on the Framework forum:

It looks like there are devices are there but just unavailable.

> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: 92HD95 Analog [92HD95 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I have noted there seems to be a history of Framework machines and no audio output with HDMI on previous generations as well. So this could be an issue with the platform itself.

Any thoughts or ideas on generating useful reports to help with this situation would be great. I would love to see Framework be successful, especially with openSUSE powering it.

The best place to start is by providing the audio chipset and driver information. Run the diagnostic script ( as explained here:

Share the link that it provides here so that others can review the uploaded output. It may well be likely that a bug report is required, depending on what is found here.

You can try testing your sound at the ALSA level first, using the ‘aplay’ and ‘speaker-test’ commands (specifying the HDMI devices)…

Here is the result of that script:

This is what I tried, maybe I am doing it wrong but I did not get any sound out of the HDMI device.

> aplay -L
    Discard all samples (playback) or generate zero samples (capture)
    Rate Converter Plugin Using Speex Resampler
    PipeWire Sound Server
    Plugin for channel upmix (4,6,8)
    Default ALSA Output (currently PipeWire Media Server)
    HDA Intel PCH, Generic Analog
    Default Audio Device
    HDA Intel PCH, Generic Analog
    Front output / input
    HDA Intel PCH, Generic Analog
    2.1 Surround output to Front and Subwoofer speakers
    HDA Intel PCH, Generic Analog
    4.0 Surround output to Front and Rear speakers
    HDA Intel PCH, Generic Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HDA Intel PCH, Generic Analog
    5.0 Surround output to Front, Center and Rear speakers
    HDA Intel PCH, Generic Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HDA Intel PCH, Generic Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    HDA Intel PCH, Generic Digital
    HDMI Audio Output

Playback on Default works but this is the error I get with the HDMI device.

> speaker-test -c2 -l5 -twav -D hdmi:CARD=PCH,DEV=0

speaker-test 1.2.9

Playback device is hdmi:CARD=PCH,DEV=0
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 1048576
Period size range from 32 to 524288
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Write error: -77,File descriptor in bad state
xrun_recovery failed: -77,File descriptor in bad state
Transfer failed: File descriptor in bad state

Thank you for any help you can provide. I will write whatever bug reports are necessary. Outside of this one issue, I absolutely LOVE the Framework laptop and hope that this company will continue for many years to come.

In your opening post, I note the graphical volume mixer shows “Digital Stereo (HDMI) Output + Analog Stereo Input” option. Does selecting that result in audible sound?

Hmmm… the output didn’t show anything obvious, but I note from a quick search using ‘Framework HDMI’ (and similar) there are a number of issues reported across various Linux distros.

In this example, the user claims

"Update: HDMI audio disconnect is reproducible by changing PulseAudio configuration from Digital Stereo (working) to 5.1 Digital Surround, then back to Digital Stereo (not working).

To get the audio working again requires the HDMI cable disconnected and/or the computer restarted."

Similar thread but no resolution…

Otherwise, consider raising a bug report, and submit the diagnostic data shared here already…
Some guidance aorund submitting reports…

1 Like

Bug report submitted!

This is now resolved, thanks to the fantastic openSUSE community!

Yes, I read the bug report updates. We are lucky to have Takashi Iwai as an experienced audio developer and openSUSE maintainer. Glad to read that it is now resolved for you.

1 Like

That is so absolutely true. I am very grateful for his patience with me and perseverance in getting this resolved.