No GUI after upgrade to 11.3

I have followed this article SDB:System upgrade - openSUSE to upgrade from 11.2 to 11.3 using the CLI. After installing I cannot boot into my GUI. I am using an NVIDIA card 7800. It will attempt to got to the log on screen, but will remain in a black scree with just mouse activity. Not sure what the issue is.

Try rebooting again, but this time insert the value ‘nomodeset’ in the grub boot menu (see this sketch): File:Nomodeset-example.jpg - openSUSE
http://thumbnails31.imagebam.com/9368/60422a93679296.jpg](http://www.imagebam.com/image/60422a93679296)
You may find this guide of help: SDB:Configuring graphics cards - openSUSE

That is what I had already had in there . from what i gather it has something to do with the NVIDIA drivers.

I have removed the NVIDIA drivers and continue to be greeted with a black screen with just the mouse. Since Sax2 has been removed are there any other ways to troubleshoot a graphics issue?

It appears you have tried various things and made no mention of them, making it very difficult to give a useful recommendation without wasting time.

For example in response to the recommendation to try ‘nomodeset’ you replied you had already tried it:

and then you noted:

At this stage I do not know what you have on your system. When did you install the proprietary nVidia drivers? How did you install them ? What did you do to remove them? Did you try the nouveau driver? Did you try the nv driver? Vesa? FBDEV? Did you try a Failsafe boot ?

Sax2 is available in at least one (and possibly more) home repositories of some users of the build service. But sax2 is no longer maintained, so even if you install it, you may find it won’t help.

Did you read the link I already provided above ? ie : SDB:Configuring graphics cards - openSUSE

and some basic graphic card theory: openSUSE Graphic Card Practical Theory Guide for Users

Yes I have read both threads. Specifically I have followed everything from: SDB:Configuring graphics cards - openSUSE through to step 6. When I attempt to startx from a normal user I receive the following error from /var/log/Xorg.0.log :

77.027 (EE) NVIDIA: Failed to load the NVIDIA kernel moduel. Please check your
77.027 (EE) NVIDIA: systems kernel log for additional error messages.
77.027 (II) UnloadModule: “nvidia”
77.027 (II) Unloading /usr/lib/xorg/modules/updates/drivers/nvidia_drv.so
77.027 (EE) Failed to load module “nvidia” (module-specific error, 0)
77.027 (EE) No drivers available.
77.027
Fatal server error:
77.027 no screens found
77.027

I have installed the drivers via this article SDB:NVIDIA drivers - openSUSE using “The repository way”

uname -r:
2.6.34-12-default

I have to type everything out as I am not able to pull it off the machine. I hope this helps.

Do you have a digital camera ?

I no longer retype off a screen. Its too slow. A digital camera works wonders.

Now, you say you removed the NVIDIA drivers. Exactly what did you remove ? Also, when you are booting, are you booting with, or with out the “nomodeset” as a boot argument? Also, in ADDITION to ‘nomodeset’, did you also try blacklisting the ‘nouveau’ driver in the /etc/modprobe.d/50-blacklist.conf file per the steps that you have quoted ? (or did you just read them and decide you did not want to apply them ? ) … Also have you tried booting with the Failsafe settings ?

I applied every step up until 6. I was booting with nomodeset as well as the blacklist described in the wiki. The way I have been removing the drivers is by using Yast just removing the packages. Here are some screen shots:
Here is my initial Grub screen:
http://img130.imageshack.us/img130/5600/img2010081900028.jpg

After booting with option nomodeset. I receive this:
http://img835.imageshack.us/img835/6291/img2010081900030.jpg

I hit ctr-alt F1 and get here:
http://img820.imageshack.us/img820/592/img2010081900031.jpg

I assume its booting there because it cant start X?

I log in and try to start x and receive this:
http://img820.imageshack.us/img820/592/img2010081900031.jpg

The way I have been removing the drivers is by deselecting the package via yast. Here is what I currently have installed:
http://img42.imageshack.us/img42/629/img2010081900034.jpg

Hope this helps

This may be the dopiest post you read today, but I have no self esteem, so here goes:

I have the 7800 card. I am using the nouveau and nouveau gallium driver with satisfactory results. However, it takes a long time for the gui to start! You may be alright if you just wait. It seems like forever but is really less than a minute. I observe the same activity as you: black screen, responsive mouse. But, after a bit, the gui comes up.

Patience might be the answer, along with rolling back the driver until you get things sorted out.

I think I have let it sit before, but I will let it sit again, and report back. It looks like its going to load, because you can see the mouse working. It actually booted to the GUI when I first performed the upgrade. The graphics where crappy compared to 11.2 so I figured I would update the drivers. That is what got be squirrelly. I though i was rolling back the driver by removing the packages via yast. I am sure that’s not the correct way but its the only way that I know how.

Still no joy. I waited for quite a while.

Hmmm … I am not very familiar with the run level 3 yast for software package management.

What do you get if you type:

rpm -qa '*vidia*'

Did you try booting to failsafe ?

Yes I have tried booting into failsafe it does the same thing. Here are the results from rpm -qa ‘vidia’ :

rpm -qa ‘vidia
x11-video-nvidiaG02-256.35-15.1.i586
nvidia-settings-256.35-0.pm.1.1.i586
nvidia-gfxG02-kmp-default-256.35_k2.6.34.0_12-14.1.i586

On 2010-08-19 20:36, ice2921 wrote:
>
> Yes I have tried booting into failsafe it does the same thing. Here are
> the results from rpm -qa ‘vidia’ :
>
> rpm -qa ‘vidia
> x11-video-nvidiaG02-256.35-15.1.i586
> nvidia-settings-256.35-0.pm.1.1.i586
> nvidia-gfxG02-kmp-default-256.35_k2.6.34.0_12-14.1.i586

which means you do have the proprietary drivers packages installed. And one of them from packman.
The yast screen shows the same info.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

So do i need to remove them ?

Yes. To remove:

su
rpm -e $(rpm -qa '*nvidia*')

Then after removed, reboot,

shutdown -r now

and try rebooting with and without ‘nomodeset’ boot code.

Ok I was able to boot into a GUI after performing a repair, and the graphics are very fudged. So now that I am able to boot to the GUI what is correct way to install the NVIDIA drivers?

For some reason now I can only boot into failsafe . I do not even have an option to boot in to default or desktop.

Explain please.

Maybe take a picture of the grub boot menu so we can understand what you mean.

Did you type ‘nomodeset’ as a boot option for a regular boot ?

When you say ‘default’ or ‘desktop’ it suggests to me you installed two different kernels which is not a good idea for users with limited openSUSE experience.

No I did not. What I mean is that if you look here :
Default Re: No GUI after upgrade to 11.3

I applied every step up until 6. I was booting with nomodeset as well as the blacklist described in the wiki. The way I have been removing the drivers is by using Yast just removing the packages. Here are some screen shots:
Here is my initial Grub screen:
http://img130.imageshack.us/img130/5...0081900028.jpg

The first option in that picture “default” is not longer there. It just boots to the GUI in failsafe.