no Gnome option in Session_Types

Hi to All,

I have openSuse 11.2 64 bit on my desktop machine. I have both KDE and Gnome installed but have no option called Gnome in the Session_Type list.

Am I missing some packages?
Could someone help me to be able to change to Gnome?



sumi76 wrote:
> Am I missing some packages?

YaST > (give root pass when asked) > Software Management > flip
“Filter:” from “Search” to “Patterns” > scroll to “Graphical
Environments” > place check mark next to “GNOME Desktop Environment”
and “GNOME Base System” > Click “Accept” > right click desktop select
“Log Out” > select “End Current Session” > click on “Sessions” > Pick
GNOME . . .

to get back to KDE (if you want) Log Out > select “End Current
Session” > click on “Sessions” > Pick GNOME


Hi palladium,

thanks for the hint. As I think that all the mentioned packages are installed, my guess is that the magic words are: End Current Session.
It might be obvious for the rest of the world, but I thought that after user logout I should have the option to switch to Gnome… (I’ve never tried the ECS option)
See, I’m pretty new to Suse and KDE.
I will give it a try on Monday.

Thanks again!


> I will give it a try on Monday.

welcome, and good luck…

and, if you normally log in when you first boot up, you can select
Session then also!

and, the Sessions will always default to what you used last, so if you
log out of Gnome, then it will Gnome…


It seems, that I am in deed missing a great deal of packages.
But to make it more interesting, here’s the error message I get when selecting “GNOME Desktop Environment” for installation:

#### YaST2 conflicts list - generated 2010-02-22 09:51:24 ####

pattern:gnome-11.2-20.22.1.x86_64 requires patterns-openSUSE-gnome, but this requirement cannot be provided
uninstallable providers: patterns-openSUSE-gnome-11.2-20.22.1.x86_64[openSUSE 11.2-0]
     ] do not install pattern:gnome-11.2-20.22.1.x86_64

     ] break gnome by ignoring some of its dependencies

     ] deinstallation of patterns-openSUSE-kde4_pure-11.2-20.22.1.x86_64

#### YaST2 conflicts list END ###

Selecting “GNOME Base System” is fine.

How to resolve this problem?

patterns-openSUSE-kde4_pure-11.2-20.22.1.x86_64 is not essential to KDE. It doesn’t include any package either:
zypper info -t pattern kde4_pure

I think you can safely deinstall it.

Well then, I will remove it.

Thanks for your kind help!


The kde pure is fine to remove, it just holds kde installs pure to kde and obvoiusly lets you know when you have broken that or are about to. For example if you went to install compiz on a kde box you would have to break kde purity.

Thanks to all of you, Fellows!

My problem is solved!