no firmware option


I have a qcow file which needs uefi to boot.
I know I need to setup a new machine and check the box to change the configuration and then select it in the Hypervision details but nothing to select, only the Chipset

all ovmf packages are installed (and reinstalled) but nada… so what am I missing :slight_smile:

thank you for your anwser


I use pc-q35-4.0 for UEFI boot with qemu.

You haven’t fully explained what you are doing.

I normally use “virt-manager” for this.

With an existing “qcow2” file, …

Hmm, I’ll do one right now to get the details. As I write this, I am cloning an existing virt machine. Then I will delete the machine but keep the qcow image, and use that.

That took a while.

On the first screen, I checked the box to import existing image.

On screen 4 (labeled “Step 4 of 4”), there’s a box “Customize configuration before install”. I check that box.

That brings up a new screen for customizing. On this screen, there is a firmware option (defaults to BIOS). I selected the “ovmf” option there. When I click “Apply” to apply the changes, it shows BIOS again (this is with Leap 15.2), but I ignore that because, from experience, I know that it actually has gone with the “ovmf” firmware.

When I then click “begin installation”, it completes the setup and boots the machine using UEFI.

Once the machine is setup, there isn’t any choice to change the firmware. The only time I am able to do it is on that setup screen.

There’s another way that I have done this, and that’s using “virt-install” which allows me to specify an ovmf firmware that isn’t offered in the way I described above. I’ve used that to experiment with 32-bit efi firmware on a 64-bit virtual machine.

In the following article,
Skip down to the “Advanced Hypervisor Confiugration” setting, you’ll find a setting to specify the UEFI firmware path


Interesting it shows the old chipset? That could also be frustrating for the user going forward if they don’t move the vars and code bin files out of the system directory, next update to ovmf will likely mean another visit to the the BIOS setup to reconfigure… Learnt about that issue using qemu, or maybe it’s just a qemu thing… likewise the fd file is a Centos thing, openSUSE uses two files…

Hello nrickert and tsu2,

This is exactly what I am doing, however firmware option box does not appear, i know it should be there but it is not. Only the chipset type is there and can be changed.

That is what i meant with i can’t select anything.
It should appear once the ovmf package is installed but it does not…


I’m not sure why you are having that problem.

If it is any help, here is the command that I used a few months ago, with “virt-install”.

virt-install --name twjump --memory 2048 --vcpus 2 --disk /var/lib/libvirt/images/twjump.qcow2 --machine q35 --features smm.state=on --boot loader=/usr/share/qemu/ovmf-x86_64-ms-4m-code.bin,loader_ro=yes,loader_type=pflash,nvram_template=/usr/share/qemu/ovmf-x86_64-ms-4m-vars.bin,loader_secure=no --import

I ran that as root. I kept a copy of the command as a template for future use.

The “–disk” option specifies the image that I am importing, and the “–import” is what tells it to import (really, to boot that image).

The user has not indicated chipset selected… your machine q35

I was just copying what worked. But, yes, I would suggest leaving that part out. As far as I know, “virt-install” will select reasonable defaults for what is not specified. The “–features smm.state=on” can probably also be left out.

That’s what I meant, user needs to ensure it’s (chipset) selected for UEFI :wink:

I looked into the commandline to but what to select is bit vague.
I will continue tinkering with it, there has the be a reason it won’t show in the gui.

thanks for all for the input

sorry for the delay, been a little since I had time.
did a roll back and then a reinstall via yast of the kvm stuff, now it shows up :slight_smile: