No effects x1650pro agp

When I install OpenSUSE 11.0 everything seems to work fine, but I cannot enable any kind of effects. Without ATI drivers, glxgears works but everything, except the wheels window, locks up. I tried the 1-click installer from the opensuse site but after rebooting I get a white screen, with the cursor working perfectly but it’s just a cursor on a white screen :eek:. I also tried to install the latest drivers, 8.6, and the same thing happens. What should I do or what driver to try? :confused:
My video card is Sapphire x1650pro 512mb on AGP. I know that on the ati section they say that 8.4 drivers are broken on opensuse 10.3 but i don’t know what to do, as this shouldn’t apply to me as I have opensuse 11.0 and 8.6 drivers.

I have a similar card (ATI-branded, but manufactured and sold via Visiontek) and also AGP, but have no problems with it whatever (I also did the 1-click install). However, there is a known issue with SaX2 (originally happened with 10.3, and is still true with 11.0) that requires you to run (after the install and required reboot):

sudo sax2 -m -r 0=fglrx

from a failsafe Xterm (no window manager) session. (While you can drop back to init 3 and a plain command-line and run as root, you don’t have to; you just can’t be running a windowing manager. Afterwards, simply logout then log back in to your preferred desktop.)

In fact, 11.0 GM runs better than 11.0 RC1 did (with the same driver, no less). Apparently, something got done right.

I run opensuse in terminal mode, I tried the command you posted and it says that sax2 is not a valid command :stuck_out_tongue:
Before the ati driver installation finishes it gives me an error but I can’t remember what was it, I know it happened when it was doing something about kernel (in the installation status).

what worked for me (one of the guys on phronix told me this one so I can’t take all the credit) go into your computers bios at boot and manually set your agp aperture to match your cards memory, ie if you have the 512 model set it to 512 if 256, 256 you get the message. Then do a full update and use yast to reinstall your drivers.

note:the error you were getting when manually installing the drivers is most likely from not having a symlink at /usr/src/linux to your kernel folder. Either that or you need to install the kernel source package.

It won’t work, I already set AGP Aperture size from the BIOS when I first installed the video card under Windows, I mean the agp aperture size was already set correctly when i tried to install the video card card under opensuse.
1-click installer don’t work for me, it says that it cannot download some files, so I tried with the drivers I found on
I will try to explain once again the problem: my 3D acceleration seems to work fine (about 250fps with glxgears) but when I try to enable any kind of the effects, the screen turns white. I think it it already white when entering the desktop because from what I know, opensuse automatically starts compiz when it detects 3d acceleration.