No driver for HP LaserJet P1006 printer ?

I can’t make work my HP LaserJet P1006 printer on USB with OpenSUSE.

It’s being detected as usb://HP/LaserJet P1006 but there is no specific driver for it.
I try to use the generic HP LaserJet driver but didn’t work.
There is no driver for P1005 model, either.

Someone had the same problem here: Cups Printer Driver Incompatibility Hp Laserjet P1006 Printer

Any ideas?

Have a read of this page.

The driver is here.

Thank you for the links.

It’s quite difficult to install the way described there (for example, when I type


nothing happend (bash: make: command not found)

I downloaded the driver foo2zjs.tar.gz and tried to install it by YaST. It seemed to install OK, but still no printing.

When you want to build something by using make, etc. you should install make, etc. first. Use YaST and install at least make, gcc. When it is a kernel module you try to generate you need kernel-source.

Thanks deano_ferrari and hcw for your help, my printer is now working.

Excellent. :slight_smile:

Friends, I have just bought this device and tried to make it work on OpenSUSE 11.2 and 11.0.

On 11.0 it works fine with HPLIP(there are proper drivers) and everything is fine.
The printer is not detected properly via USB, so simple USB setup fails.

On 11.2 the system autodetects the printer and sets it up, but the setup is broken.
It detects both USB and HPLIP connection, but when I start printing (with a proper driver) CUPS webinterface says “/usr/lib/cups/filter/foomatic-rip-hplip failed” (for HPLIP), the printer stops then.
What is wrong here?

I have homeserver with OS 11.0, where the printer works with HPLIP
On the client PCs there is OS 11.2, and the printer doesn’t work on it.
I want to print over network.

And to prove that this scheme works, I have another printer HP photosmart C5283 working perfectly and had Samsung ML1520 working, until it broke down.

Thank you!

The problem is obviously in OS 11.2 support. I’ve made several tests, and found out that the printer perfectly works as local printer from 11.0 and as network printer from Vista… But it doesn’t work from 11.2: neither as local USB printer, nor as network printer, with old and new ppd’s.

Any ideas?

I have tried upgrading CUPS and downgrading HPLIP (with drivers). Nothing helped.

BTW, when I print over the network from OS 11.2, the CUPS server (on 11.0) marks the job as “completed”, when in fact it is not. Printer is just idling - no errors, no “wakeups” - nothing.

No ideas?

A friend of mine has bought hp p1005 and experienced right the same problem.

Despite all warnings, the foo2xqx driver helped me out.

Strange thing. If the standard driver does not work out of the box, why it is there?


HP LaserJet P1006 driver for click here

good luck

Beware. This link offers a windows/linux driver that is an .exe windows executable. The download link seem to be masked (hovering over shows a html page, not the actual .exe file). I don’t think this is a safe download for windows users, and it certainly is not for linux.

  1. Click on the Application Launcher, choose “Yast: Administrator Settings”, and enter the super user password when prompted.

  2. Scroll down, choose “User Management”, select your user profile, and choose “Edit”.

  3. Under the Details tab ensure that the “lp” group is checked, click “Accept”, and click “Finish” on the next dialog box to exit.

  4. Log out, then log back in, and run hp-setup.

  5. Launch a command-line window and enter:


  1. Select your connection type and click “Next”.

  2. Select your printer from “Selected Devices” list and click “Next”.

  3. Enter your root password when prompted and click “Next”.

  4. Use the recommended installation method and click “Next”.

  5. Check the box to accept with the “Driver Plug-In License Agreement” and click “Next”.

  6. Finish the installation of the printer as normal, however you may be prompted to re-enter your user name and password.
    __________________HPLaserJet P1005 and HPLIP not work in 11.2 - openSUSE Forums

Thanks, Nikolai! I thought this would be a big problem but thanks to your post it took me 2 minutes.rotfl!