No display after suspend

After doing the zypper dup yesterday my monitor failed to wake up after suspend. Even if I turn off and turn on the monitor fails and can not detect tumbleweed.
I am using Xfce. Everything was fine before the upgrade. I am using the latest nvidia driver
Any thoughts? if you need more info please tell me what info shall I provide.

Thanks in advance.

With “The hard way” installation you need to reinstall Nvidia drivers after TW upgrade (changing kernel).

Thanks for your reply. Yep it’s been the practice to reinstall it every time.
My concern is the monitor (display) that is not detecting the OS after waking up from suspend.
Oh, this was the first time I zypper dup tumbleweed after two months cause I was busy doing some other
stuffs and did not touch my machine for a while. I also noticed that the previous driver before this
nvidia driver I am using is not installable with the newer kernel.
Best regards and thanks in advance for any advice I can get.


inxi -Gxxxz
  Device-1: NVIDIA GK106 [GeForce GTX 650 Ti] vendor: ZOTAC driver: nvidia 
  v: 470.63.01 bus-ID: 01:00.0 chip-ID: 10de:11c6 class-ID: 0300 
  Device-2: NVIDIA GK107 [GeForce GT 640] vendor: ZOTAC driver: nvidia 
  v: 470.63.01 bus-ID: 04:00.0 chip-ID: 10de:0fc1 class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: nvidia resolution: 1920x1080~60Hz s-dpi: 96 
  OpenGL: renderer: NVIDIA GeForce GTX 650 Ti/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes

They’re old cards on an old machine. The boot device is the GeForce GTX 650 Ti
The lower card, I only use it as addition for rendering in blender.

I think I found the culprit.
In the yast2-service manager, there are lines for nvidia resume, hibernate and suspend, first time I’ve seen this.
I think there was no nvidia service before if I am not mistaken. I turn all of it to not start on boot and to start manually
and my display started working again after suspend. Hopefully it was really the culprit so I can say the problem is solved.

Please consider this issue as solved.
Thanks for your replies.