no device network displayed

hi

since 20220518, under kde no network device are displayed.

NetworkManager-wifi is not installed, I don’t have it on my other computer and I don’t have this issue (don’t have yet the update).

i have an intel ax201 wireless card.

thanks

In Tumbleweed networkmanager-wifi is no longer a default - you have to install it to get it.
This was done to make smaller server images for the cloud that only connect ethernet.

My 2 cents is why would you run a rolling distribution on a cloud server?

never said i installed that on the cloud… my issue is on a desktop computer…

like i said i don’t have this issue on my other laptop who don’t have this package… will try to install it to see if that fixe this issue…

seem like with NetworkManager 1.36, libnm-device-plugin-wifi is installed…

with newest version of NetworkManager, we need to add NetworkManager-wifi to get the same result

Hi
The latest and greatest :wink: all depends on your deployment needs, some spin up, do something and destroyed… I use it here with vagrant, spin up an instance, try something out and destroy, or if running ok just keep updating if needed.

After installing (?) NetworkManager-wifi (assuming you plan to use Network Manager), you may wish to research if the Intel AX201 support is integrated yet in the kernel? I read some months back of Ubuntu, RedHat and other distros could not get this device to work with their kernel …

I note from Linux Hardware: https://linux-hardware.org/?id=pci:8086-a0f0-8086-0234 :
The device is supported by kernel versions from 5.7 to 5.12 according to the LKDDb, but I don’t see openSUSE in that list of compatible GNU/Linux versions … although perhaps no one has tested it yet and updated Linux hardware.

If it were me with the issue, I would check my tumbleweed kernel install for the appropriate kernel module/driver.

wpa-supplicant appears to be missing as well in Tumbleweed update for NM.

Tumbleweed made that change for servers (so they will be smaller in the cloud) - it affects everyone. It should have looked for a wifi device and installed it

What they really should do is if you have installed any desktop (not server) install the NM-wifi and wpa-supplicant - just don’t install them for server images.

Hi
The problem may also be user induced (as I’ve seen [ML, IRC]), it’s a recommend, if users have modified the config to not install recommends,…

yes, that would be me. And finding the effing LAN adapter to fix this took longer than googling via the erfing mobile phone for a solution. Now, I can fix that but I probably need to drive to my relatives that have the same setup. Grr

This is almost as bad as the last kernel not booting because someone thought selinux autorelabel would be a nice addition to a non-selinux system. I had to add selinux=0 to kernel opts. Well, alright, no fun without risk

No risk whatsoever: https://en.opensuse.org/Network_Management_With_Systemd Have a lot of fun!:wink:

interesting! I do have the cabled computers set for wicked and never heard of this one. Bookmarking it, thanks.

As for continuing the no-recommends story: it did hit my family today. I spent an hour creating phone screencasts to explain how to download the nm wifi rpm onto the phone, copy it to OTG SD card, put the card into laptop, open rpm with yast and installing it lol! Oh my, and all this hassle for 160K saved by splitting off wifi. And speaking of recommends, another relative, this one running Leap, has recommends enabled but 3000 entries in his zypper lock list to block unwanted recommends, namely texlive which for unknown reasons is recommended by extra fonts pattern.

NetworkManager is default network management program in Tumbleweed and likely will be in SLE 16, so it will be present in almost every installation. If you multiply 288K (not 160K) by thousands of containers running SLE or openSUSE, it starts to matter.

texlive which for unknown reasons is recommended by extra fonts pattern.

That would be topic for bug report.

yea, alright, I get it. Was just upset because this change came unexpected for me as I never even thought about my laptop being driven by a cloudinit os with a graphical desktop lol!

Default can configured in /etc/zypp/zypp.conf

## 
## Whether only required packages are installed. 
## 
## Recommended packages, will not be regarded. 
## 
## Valid values: boolean 
## Default value: false 
## 
solver.onlyRequires = true