No Desktop Effects in Live OpenSUSE 11.3 Gnome

Hi everyone. Im trying out popolar distros running on Gnome… to see possible installation candidate :slight_smile:

And having one problem with OpenSUSE 11.3 Gnome out of the box…
I can not enable desktop effects… it says it can not be done on my hardware configuration…

My hardware: AMD Athlon 64bit 3000+, Ati Radeon X600 256MB, 2GB DDR2, 160GB HDD…

In every other distro I tried from live CD… I could enable desktop effects… Now I have tried update in that live session… and when gone to that software application it asked and I downloaded 130Mb of software… flash player…etc… but I still did not have desktop effects… So my question is can it be done with my configuration… Works fine in ubuntu with Open drivers (radeon)…

I would really like to make it possible on live CD… because I dont wanna install and then see that I can not enable it…

I know that most driver manipulations need restart… so live session can not do that…
But can you say if I could even make it happen on Raden X600? No problems in Fedora, Ubuntu…

thanks for any help

(Edit: Ooops…didn’t notice reference to Gnome DE on first skim read.)

What does this output show? (Just the grpahics-related entry)

/sbin/lspci -nnk

Have a look at /var/log/Xorg.0.log for any errors or clues about which driver is in use.

For comparison, I have a 5 yr old ThinkPad, running openSUSE 11.3 with a X300 chipset and radeon driver in use. Desktop effects are enabled and working ok.

thank you for zour reply alot.

ok, now Im in live 11.3 and graphic entry of lscpi is:
05:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV380 0x3e50 [Radeon X600] [1002:3e50]
	Subsystem: Giga-byte Technology Device [1458:2100]
	Kernel driver in use: radeon
05:00.1 Display controller [0380]: ATI Technologies Inc RV380 [Radeon X600] (Secondary) [1002:3e70]
	Subsystem: Giga-byte Technology Device [1458:2101]

It seems that Radeon driver is in use, but still if I trz to enable desktop effects I get >

Desktop effects are not supported on your current hardware / configuration. Would you like to activate them anyway?

Havent seen any errors in Xorg.0.log but dont know where to look, most of it refers to RADEON…


I do not have direct rendering… that I can tell from several commands I used in ubuntu… like glxgears and glxinfo | grep “direct rendering”

I’m not sure why direct rendering isn’t being enabled, and I don’t have an openSUSE LiveCD to test with.

However, I did find a bug report concerning ATI hardware and the openSUSE 11.3 Live CD distro (submitted by oldcpu):

I wonder if you might be experiencing the same issue here. I think you’d find if you acually installled (along with updates), all was ok. (I haven’t seen any problems for those with same graphics hardware running openSUSE11.3 with Gnome or KDE4).

thank you for your reply…
Is there a way to restart this live session wihout loosing all I done… seems impossible to me, because Im doing updates now… and Im interested will they help… if nothing else maybe Ill try to install these days…

edit> is there something else concerning drivers I could check out… while Im still in this live session… :slight_smile:

You can’t really update a Live disk it is all in memory.

You can do that by restarting just X server.
Alt+Ctrl+Backspace key combo enables that.

You can also do this by switching to runlevel 3 and then back to runlevel 5 or by manually killing the X process and then restarting it manually by typing startx in the console. It should allow to switch driver without rebooting and so the updates you’ve made on the live CD’s ram disk should make a difference.

For example I installed drivers for wifi on a live CD and affected the system without rebooting using modprobe and it actually worked.

thanks you both for info and help… will try something these days, and will be back with feedback :wink: