No Boot(ACPI, Newly Persistant Problem)

I just purchased an HP 1030NR (WebBook) and LG MultiDVDBurner.

The original install of openSUSE 11.0(Linux Pro Mag Nov08 DVD Edition) went without a problem. I installed(ndiswrapped) the WLAN drivers. Then updated all the packages. This was all 2 days ago.
Today I took my laptop to work this morning and it refused to boot normally, it worked in fail safe mode, so I used trial and elimination to discover I can boot it with the acpi=off, there is no noticable speed difference. In the trial and error process I’ve noticed I can no longer boot the installation disc without choosing No ACPI!

When Booting with acpi on it halts with a blank screen right after loading the kernel(Where it normally says openSUSE)
I’ve tried acpi=strict and pci=noacpi.

Any sugestions?
Thanks in advanced.

Does the following boot option help?




Thanks for the reply,
Sadly, Neither work
–Could this be a hardware failure? since the Install DVD used to boot without the acpi=off as well

I would not think so.

ACPI involves a group of tables describing the hardware that the bios produces for the OS, to use for power management of various devices. It is now the default source the OS uses for mapping the hardware, vs the legacy method (the bios also produces what is simply called a “hardware map”). Unfortunately, the ACPI standard is loosely (some say poorly) defined and consequently there are variations in how bios’s write the tables, and there are often flaws. This can result, e.g., in the kernel being unable to initialize a particular device. Consequently the kernel has code to sort of figure out and work around these issues, but sometimes that doesn’t work - and consequently, the “acpi=off” argument.

On some machines, disabling it is of little or no consequence. For example, slowing the fan may be controlled in the bios instead. And cpu throttling may not be supported by the processor anyway. On the other hand, acpi is important in laptops for conserving the battery charge; IIRC it is also required for suspend and standby.

What I don’t remember - there are others here much stronger in this area than I - is whether acpi=off disables the kernel from using any power mgmt features. It seems conceivable that acpi is not a binary choice, i.e., that the kernel may be able to do certain of such functions, or may be able to work around the table problem to some extent. Since you have a laptop, would be worthwhile to search the hardware sub-forum, post a question there, do some more searching, to see what if anything the kernel can do with that argument in force, and what other options you may have. By the way, if you search in YaST Software Mangement on “acpi” you’ll see several tools there that report on your acpi status (I think you could use these to verify what is enabled after using that argument), your settings, and an Intel tool that checks your bios tables for flaws.

Sorry I can’t be of more help.

Problem solved, in a weird way…
I used the HP XP install disc to delete the EXT3 partition.
Now the OpenSuse 11 Installer runs without locking up(again).

I’d like to find out more about this problem to help future HP Mini 1030NR users so I will continue to research the previous ACPI issue/ Perhaps cause it again… if I can. I’ll look into those ACPI tools.

Thank You.
–Zachary Stoll–

Thanks to you for sharing that discovery. I confess that I would never make the connection between a partition and ACPI. If you should learn more, it would be very much appreciated if you posted what you learn back here.

It seems to hang at ACPI: bus type pnp registered
is there a way to turn off pnp?

If you wish to try different boot codes, to see if any make a difference, you could try going thru those mentioned here: SDB:Kernel Parameters for ACPI/APIC - openSUSE

Another boot code to try is:acpi_osi=!Linux Note Linux is case sensitive.

Look for it in the bios. That’s “plug’n’play”.

And you can try the irq related acpi kernel arguments, e.g., acpi=noirq.

I think I found the problem… ACPI reports a really screwed up release.

acpi watch 0.75
(C) 2002 Oliver Diedrich

System information

System: Hewlett-Packard HP Mini (Notebook); serial #: ##########
BIOS: Hewlett-Packard 361A0 Ver. F.03 (10/24/2008)
Board: Hewlett-Packard 361A (KBC Version 02.0C); serial #:
CPU: Intel Intel(R) Atom™ CPU N270 @ 1.60GHz, 1596 MHz
RAM: 896 MByte
Kernel: Linux for i686 (build #1 SMP 2008-10-21 16:30:26 +0200)
ACPI: release ɿ�����؉�&��ɿ����������ɿ�E��������ɿ�E��

ACPI related syslog messages:

ACPI Exception (utmutex-0263): AE_BAD_PARAMETER, Thread F6C2D020 could not acquire Mutex [1] [20070126]

You might want to take a look at the “firmware” package written by Intel, it’s in the repository.

I couldn’t find the package ‘firmware’ I tried ‘firmwarekit’ (samething thats on the SUSE 11 boot DVD) and that reports good… only on the first boot after I boot windows once the second time the system freezes at that error again

I also found that ACPI reports an error and fails to boot only the second time of booting linux, to boot linux and use ACPI, I have to boot windows each time before loading linux or it will fail at the above error…
This may be caused by
PnPBIOS: Disabled by ACPI PNP

Is there a way to disable that? asside from downloading the source of ACPI and rebuilding it with all the disabling commented out?

I would be looking at, maybe in the bug reports. Found this patch code which may be what is throwing the error; looks like turning off acpi and turning off pnp causes it. More explanation here Re: [PATCH] ACPI: don’t walk tables if ACPI was disabled.

Try googling: “PnPBIOS: Disabled ACPI PNP”