No audio via speaker - headphones OK

Hi there,

having trouble getting my speaker (it’s actually a mono speaker) on my Panasonic CF-SX3 notebook to work (Haswell-ULT).
I’m using the 20190205 built and Gnome 3.30.2.

  1. Headphones work without an issue,
  2. When I unplug my headphones, Gnome sound settings automatically switches to “Speakers - built-in audio” / Profile: analog audio, but nothing.
  3. I have already tried another distro (Ubuntu 18.04) and KDE with the same result.
  4. Speaker worked fine in Windows 10

Help would be much appreciated :wink:

I’ve had issues like this before. Playing around with the settings in pavucontrol allowed me to easily see what the problem was - audio was muted on output devices I think.
If you haven’t got it installed do

zypper in pavucontrol

and try going to ‘playback’ and ‘output devices’ tabs when playing media with an audio stream to see if audio is actually being channelled to device.
‘Configuration’ tab will also give information on your current profile.

Good luck, hope this helps.


I tried pavucontrol, but without success.
When I play audio it shows the bar moving, but no actual sound comes out of the speaker.

Under the configuration’s tab, it shows two built-in audio, one is default off but only contains HDMI entries, the other one shows analog stereo duplex, but it doesn’t make a difference if I choose analog stereo output instead.
The output device tab shows headphones being plugged in once I plug them in. Also the speaker entry becomes “unavailable” then and once I unplug the headphones the speakers are activated and the headphones are shown as unplugged, but no sound comes out of the speaker.

Hmm, after unplugging earphones and playing audio with an application is the volume level set sufficiently high under the ‘Playback’ and ‘Output Devices’ tabs where the application should be listed?

Another possibility is that the sound could be muted by hotkey on your notebook. Try unmuting/muting sound to see if that makes a difference if it’s available. In KDE/plasma you should get an on screen notification that audio has been muted/unmuted.
Sorry if this is not much help.

I could try to help … but I would need more information, so to understand better your laptop’s configuration.

Could you run a diagnostic script, not to immediately fix the problem, but rather to provide more information so that we might identify the problem? As a regular user, open a konsole/xterm, with laptop connected to Internet, and copy/paste the following into the konsole/xterm:


Select UPLOAD/SHARE when prompted, and allow the diagnostic script to run to completion. When it completes, in the konsole/xterm will be a web-address/URL posted, where your laptop’s diagnostic information on audio was uploaded. Please copy/paste that address here. We can then go to that address and see if it yields any clues as to the issue.

Thanks for your help. Here is the diagnostics:

Don’t be surprised it says Ubuntu 18.10, I ran the script in Ubuntu to try another distro/Kernel, but no matter the distro, the problem is the same.

With respect - the problem symptom may be the same, but the problem could be VERY different with a different distro/kernel. So frankly, I don’t think pointing out problems with your Ubuntu setup (and you do have at least 2 problems with that) can be applicable to openSUSE Tumbleweed. So you need to run that script with Tumbleweed.

As for your Ubuntu, may I humbly suggest you go to a Ubuntu forum for help on that. To give you a ‘leg up’ on that, you should fix your mixer setup, before you ask for help on the Ubuntu forum. Note this setting:

Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Front Left: Playback 0 **[0%]** -65.25dB] **[off]**
  Front Right: Playback 0 **[0%]** -65.25dB]** [off]**

Your PC has the speaker muted - so it should be clear you will not get any sound with that wrong setting in place. There are thou, likely additional issues.

Note your HDMI is card-0, and your analog sound (PCH) is card-1.

!!Soundcards recognised by ALSA

 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xf7f3c000 irq 50
** 1 [PCH            ]:** HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7f38000 irq 48

By default, openSUSE multimedia applications will send audio to the sound card-0 (unless specifically configured to send sound to sound-card-1). So if this were openSUSE and not Ubuntu, that could also be an issue if you are not trying to send sound to HDMI but were trying to send sound to the analog speakers (PCH). Is this the case for Ubuntu? I do not know. I do not use Ubuntu and I have no desire to do so. So I can not in all due honesty say if the same aspect would be an issue for Ubuntu. I believe that is a clear reason why you would benefit by going to a Ubuntu forum.

Further, I note this in the dmesg, which could be specific to the Ubuntu kernel and not to the openSUSE Tumbleweed kernel:

    3.532185] snd_hda_codec_realtek hdaudioC1D0: Failed to find dell wmi symbol dell_micmute_led_set

Would that failure also occur on the openSUSE Tumbleweed kernel? I don’t know.

Is that relevant to your laptop sound problem? I don’t know.

If you post again wrt the script output for openSUSE Tumbleweed , I’ll try to provide more support if I spot anything misconfigured. Otherwise, good luck on the Ubuntu forum.

… an additional note - I’m leaving Europe for a month in a day, and so I may not be checking the forum very often while out of continent.

Hi, thanks for your help. You pointed in the right direction, the channel simply is muted.

Now I’ve observed the following behavior:

  1. When I plug in my headphones, the channel gets automatically switched to the unmuted headphones’ channel. Speaker channel is then muted as it is supposed to be and the headphones work just fine.
  2. When I unplug my headphones, headphones’ channel gets muted and the speaker unmuted as you would think reasonable.
    The thing is, that it’s not the speaker’s channel that produce sound, it’s the headphones. So when I manually unmute the headphones’ channel the speaker works just fine. For some reason, headphones is wired for two outputs it seems.

How can I fix this?

Glad to read you made progress.

I am not familiar with Ubuntu’s implementation - so you will need to ask them.

I have an early flight tomorrow so I am off to bed. Good luck with your efforts on the Ubuntu forum with your Ubuntu boot partition.