NFS stopped working

After 2 years of good service and after I’ve changed IP addresses in the router from to my autofs stopped mounting my NAS with NFS. That was the only change. Now it gives me:
#showmount -e
clnt_create: RPC: Program not registered

rpcinfo -p

program vers proto port service
100000 4 tcp 111 portmapper
100000 3 tcp 111 portmapper
100000 2 tcp 111 portmapper
100000 4 udp 111 portmapper
100000 3 udp 111 portmapper
100000 2 udp 111 portmapper

that’s it. I’m pulling my hair out, I’ve changed the addresses back, turned off firewall - nothing helps, it just won’t automount!

Any clues? Thank you.

Was your NFS server using that router as it’s default gateway?

Good luck,

If the NAS is configured with DHCP a restart should do the job. Otherwise, indeed set the gateway address of the NAS to the router’s new IP.

Yes, the NAS is using the router as the default gateway. The router’s address is, so the NAS has both the gateway and DNS set to this IP address and is using DHCP for IP allocation.

I rebooted both the router and NAS many times, restarted autofs - nothing. I can get to the NAS through its either name or IP address - this means both the NAS and router work. It’s something to do with NFS and autofs.

I didn’t change the router’s address, I changed the NAS’s and desktop’s addresses from the range to - that’s all I did. and then autofs stopped mounting the NAS.

I may be missing here something or doing something wrong. The problem was I wanted a static IP for the NAS so that autofs could mount it. It did while both the router and NAS were ON. As soon as I reboted either of them, the NAS’s IP address got changed to a different IP and then of course autofs couldn’t mount it. I had to disconnect everything from the router and re-connect all in turn so that every device got a particular IP address. This was when the IP range was When I changed the range, all devices on the network seemed to keep their IP addresses after reboot. But autofs stopped mounting the NAS for no reason. I;m totally clueless why.

My setup is:
Router -
Subnet -
Available range -
Router set to allocate IPs by MAC, e.g. the NAS will always get based on its MAC
NAS device name is ‘dataserver’
/etc/auto.misc has not changed at all. But I tried both mounting by the device name and by IP - neither work anymore

Do you see anything wrong here?

Thank you.

Have you looked for mount error messages in /var/log/warn, /var/log/boot.msg,

No. I’ll have a look. But in general, shouldn’t rpcinfo at least show nfs running?

Ah, just remembered, I can get to the NAS with smb://dataserver/Data without a problem. So they both definitely work fine. It’s purely NFS/autofs issue I think. Because when I tried autofs with cifs instead of nfs, it still didn’t work. Does DHCP change anything on my computer? I ask this because I set hostnames in YAST-Hostnames to be able to find NAS and other servers on the network by the name rather than IP and I remember one time I opened YAST-Hostnames it was empty, then it had 1 IP address in there, then all 3 were there. I don’t understand how it all works. Maybe my hosts are messed up or something?

Could someone please tell me what’s better to use with autofs: NFS (BTW the NAS doesn’t support NFSv4) or CIFS? Which one’s faster and more secure? The NAS supports both, but as it doesn’t support NFSv4 I worry about the security.

Oh, I should add, it’s not just my desktop, but every single computer in my house stopped automounting the NAS with NFS.

I’m half way there: How to set Auto eth0 IP address

but still need help. Thank you.

Have you checked messages in /var/log/boot.msg and /var/log/warn?

Sometimes I’ve found my NFS client hadn’t started after a reboot.
IIRC, this happens when the connection to the NFS Server is broken and/or there were stale locks on the NFS mounts.
Once I started NFS Client was started the NFS could/were mounted.
Verify in YaST2 NFS Client is enabled for your runlevels for reboots.

If you have Windows clients the CIFS/SAMBA is best and easier to maintaint.
Without Windows clients then I prefer NFS as easier to setup and maintain.
Linux clients don’t have to use NFS they can connect to CIFS instead of NFS.