NFS client not connecting

Ok, so I’ve worked through my firewall woes (thanks everyone for that) but still have issues connecting to my NFS exports on my home server.

  • with Fedora I was able to see the NFS shares in Discover’s Network section, and could mount them.
  • with TW they don’t show up in Discover. (I can see and connect to the SMB shares from the same server, though.)
  • If I use:
sudo showmount -e

I get

Export list for

so it is exporting and visible.

  • I installed yast2-nfs-client to set things up graphically, the “Add → Choose” button gives me the following:
    but I have allowed nfs, nfs3, rpc-bind, and mountd through the firewall, and have even tried with the firewall disabled - same result.
  • If I enter the IP address directly in “Add” I can click “Select” and get a list of exports to mount, but all of them are empty when mounted.
  • And if I go into the NFS Settings in YaST it shows the following error, whether or not the firewall is active:

I must say, I’m out of my depth with the networking on OpenSUSE. Any help would be appreciated.

You may have already read thru this, but just in case, see if it helps … it’s for Leap 15.5, but that’s okay

I did see that article, and had gone through the YaST section of client setup. I’ve got it all set up how it says afaik.

I’ll see if I can go through some of the troubleshooting steps, maybe?

Right, so I went through the setup again and this time (after turning off NFSv4, which I’m sure I’d already tried) it worked!

So looks like I’m good now. Thanks!

1 Like

You have allowed them on NFS server or NFS client?

Strange – here on a Leap 15.5 client mounting a QNAP NAS box (NFS Server) within a private LAN, NFS v4 is behaving as expected – with IPv6: on /mnt/NAS-Bureau-001/NFS type nfs4 (rw,relatime,vers=4.2,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp6,timeo=600,retrans=2,sec=sys,clientaddr=2001:xxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx,local_lock=none,addr=2001:xxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx)

  • But, I’m on a private LAN behind a DSL Router which has a Firewall in addition to, the Firewall at my ISP – therefore no Firewall in use within the private LAN …
    Your mileage may vary …