NFS automatic (re)connect

I have a little concern about how my PC (Oensuse 10.2) connects to my ReadyNAS (NFS)

in fstab I have : /ReadyNAS/media nfs auto,intr 0 0

And that works fine if my ReadyNAS is already on. But if I switch it on when my PC is running, it won’t ‘auto’ connect. If I switch on my PC when the NAS is running, it does fine until I switch off the NAS; Mmy PC then seems to become unstable.

I have another small PC running Ubuntu w/XBMC; from it I mount the NAS with this entry : /home/atu/RNmedia nfs soft,intr,rsize=8192,wsize=8192 (took this from Ubuntu Linux: NFS Client Configuration To Mount NFS Share), and this works fine, wether I switch on the PC first or not; it seems automatic, but I didn’t find out why, looked a bit through the logs, and forums, but maybe someone has a quick answer to that, I really would have liked OpenSuse to behave the same way.

Thanks :slight_smile:

Have a look at the nfs how-to:
Setting up an NFS Client

If the entry works on your ubuntu client, it will also work on opensuse or any other client.

Generally though, the nas server should stay running, since it’s a server.