Newbie's issues with 13.2's KDE (and network manager)

Hello,

Let me first introduce myself. I am a new opensuse user after 20 years of being windows. I tried ubuntu to give life to old laptops but was a little disappointed as it wasn’t stable enough. Then I discovered SLED12 and LEAP42.1 and this time I felt a strong OS :wink:

So after trying Leap 42.1 on my HP MINI 210-2100 I had to switch to 13.2 as my Intel Graphics with ATOM N550 and GMA3150 had a big display issues and was too slow with leap (KDE5?). Opensuse 13.2 was much better for this laptop but as I am a complete linux newbie I didn’t succed in everything.

First, leaving the laptop hebernate made my Broadcom BCM4313 wifi no more able to connect. Then I installed broadcom-wl and rebooted and this made it functional again. But, when I tried to find plasma-nm in system tray I couldn’t find it. Also, there is no display showing in system tray settings like it should I guess (I saw it in a thread). So I cannot configure network. I tried wicked service in YAST but this made my wifi again not able to connect. So I switched back to network manager and reinstall broadcom-wl to make it functional again.

Could you please help me as I suspect that’s something’s wrong with my KDE but I don’t have enough knowledge to check it correctly and make a diagnosys of it ? I would like to find plasma-nm also but the only I get in systray is a shortcut to YAST.

Also, how can I make a screenshot with opensuse 13.2 to put here more info? Is there some command line to find out what’s wrong ?

Thank you and heil suse :wink:

PS : forgive my english, I’m french

Hi again,
I am trying to give more informations, as I couldn’t find any solution. If I leave my HP MINI for some minutes, it hibernates or something but cannot be awaken nor with functions keys nor with brief touching power. Only complete power reset works :frowning: and after that wlan cannot connect any more.

Maybe my issue is for network or system, not KDE I really don’t know.

Here some infos of network cards :

 /usr/sbin/hwinfo --netcard24: PCI 100.0: 0282 WLAN controller                             
  [Created at pci.328]
  Unique ID: yWPJ.AGWX_IMf7TD
  Parent ID: z8Q3.I+OjYwRBgPE
  SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: network
  Model: "Broadcom BCM4313 802.11b/g/n Wireless LAN Controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4727 "BCM4313 802.11b/g/n Wireless LAN Controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x1483 
  Revision: 0x01
  Driver: "wl"
  Driver Modules: "wl"
  Device File: wlp1s0
  Features: WLAN
  Memory Range: 0x95000000-0x95003fff (rw,non-prefetchable)
  IRQ: 16 (15069 events)
  HW Address: cc:52:af:13:56:e0
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 36 38 40 42 44 46 48 52 56 60 64 100 104 108 112 116 120 124
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484 5.18 5.19 5.2 5.21 5.22 5.23 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d00004727sv0000103Csd00001483bc02sc80i00"
  Driver Info #0:
    Driver Status: bcma is not active
    Driver Activation Cmd: "modprobe bcma"
  Driver Info #1:
    Driver Status: wl is active
    Driver Activation Cmd: "modprobe wl"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #12 (PCI bridge)


25: PCI 300.0: 0200 Ethernet controller
  [Created at pci.328]
  Unique ID: UOJ9.puXXmymftd2
  Parent ID: Z7uZ.OU3DRL9Qqi0
  SysFS ID: /devices/pci0000:00/0000:00:1c.3/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8136 "RTL8101E/RTL8102E PCI Express Fast Ethernet controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x1584 
  Revision: 0x05
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: enp3s0
  I/O Ports: 0x1000-0x1fff (rw)
  Memory Range: 0x92004000-0x92004fff (ro,non-prefetchable)
  Memory Range: 0x92000000-0x92003fff (ro,non-prefetchable)
  IRQ: 45 (no events)
  HW Address: 98:4b:e1:e9:36:be
  Link detected: no
  Module Alias: "pci:v000010ECd00008136sv0000103Csd00001584bc02sc00i00"
  Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #14 (PCI bridge)
 

Please if you can help me, cheers

Hi again,

As I had no luck with answers, maybe I put this thread in the wrong place. As the blocking problem is wifi card and loosing driver (my 11 years son cannot use it because each day after hibernating the wifi becomes unfunctional and I have ti uninstall broadcom wl, reboot, reinstall it and reboot again to make it again functional), could an admin of this forum please remove my thread to another section, like hardware for example ? Hoping to get at least one answer as I’m starting to feel alone ;)*cheers,

Moving to Hardware forum as requested…

Moved from Applications and open for posting again.

I don’t have a definitive answer here, but note that others have reported the same behaviour (different distros) with this model…

http://ubuntuforums.org/showthread.php?t=2034298
https://bbs.linuxdistrocommunity.com/discussion/1748/two-minor-problems-on-an-hp-mini-210-1000
http://www.linlap.com/hp_mini_210

My advice would be to avoid hibernating. Does suspend/resume work any differently?

You could also exaine the journal from a previous boot (following a failed resume) for errors eg

sudo journalctl -b 1

Perhaps a bug report is required.

Thank you so much Deano for removing and answering ! Maybe my thread shoud be renamed to “HP MINI 210 issues (hibernate, network, wireless)”, I don’t know if it possible?

Well, I have consulted your links (thanx for it too ;)) and indeed it might be ACPÏ issue. Fans continue to work even if I cannot bring it back after hibernating. To be worse, now the power reset is not enough, I have to reset it without power cable (battery only) and to do it 4-5 times to make it boot properly (black screen remains otherwise).

I 've put the journalctl on a txt file, how can I put it here ? I’d like to disable hibernating but I don’t know how ? What’s the difference between suspend and hibernate, where can I change something about them ? On the 3rd link it is said :

To get the fans to work properly, the ACPI Thermal module MUST be loaded, or the fans will NOT come on.
modprobe thermal - also, after suspending and resuming, you need to rmmod thermal && modprobe thermal to
get the fans working again. (Many distros have various ways to automate this)

Can I do something about loading ACPI with openSUSE 13.2, as suggested above ?

Thanx again and hopefully to get some new things to try :wink: cheers

here you can download the journalctl log txt file (hope it is allowed) :
http://s000.tinyupload.com/index.php?file_id=88656386855866191974

No, you’re best to copy/paste the text to http://paste.opensuse.org/, then post the link to it here.

What’s the difference between suspend and hibernate, where can I change something about them

Suspend is used to put the machine in a low-power state (ie a small amount of power consumed) with the entire system state saved in RAM. It is quicker to resume from. Hibernate saves the RAM to disk (in a swap partition). You can configure your KDE desktop to behave the way you want. Check out the power management settings to configure.

This might be close enough to show you where to look…
https://doc.opensuse.org/documentation/html/openSUSE_113/opensuse-kdeuser/cha.kde.kpowersave.html#sec.kpowersave.configure

Great, thanx. Here it is :
http://paste.opensuse.org/55302250

OK it’s a little bit different but I found the power management on system configuration in KDE (at the bottom).
I put “do nothing” if closing noteboook and disabled the entries with energy and suspending (screen and session) and this for three cases (power, battery, low battery), now I only have a stand-by screen in case on inactivity I guess. Hope it is not too risky for the hardware :wink:

About loading ACPI as mentioned on the third link, should I do something too ?

Well, I don’t know if it is required for your hardware or not, but here’s how you can check and load it if desired…

Is the thermal module loaded?

lsmod|grep thermal

If not load it manually with

modprobe thermal

It can be loaded at boot if needed by creating a file in the /etc/modules-load.d/ directory eg nano /etc/modules-load.d/thermal.conf where thermal.conf contains ‘thermal’.

For example, using the nano editor

sudo nano /etc/modules-load.d/thermal.conf

then add the thermal module with a single entry

thermal

Save and exit. It will load automatically the next time you boot.

lsmod|grep thermal
thermal            22971    0

Guess it means OK ?

Well, disabling suspend & hibernate didn’t resolve loosing wlan :frowning: as after reboot it still cannot connect (stucked in configuring interface while trying to connect and, after a while, I have a notification that the password has to be given, even if I configured it with YAST/wicked before). Maybe, my wlan network configuration should be changed somewhere but I don’t know what to change (it is already DHCP) ? Execution mode ? Advanced setting?
Also, after trying to modify with YAST I have a message “Network not functional” (translate from french).

Yes, it means it’s loaded

Well, disabling suspend & hibernate didn’t resolve loosing wlan :frowning: as after reboot it still cannot connect (stucked in configuring interface while trying to connect and, after a while, I have a notification that the password has to be given, even if I configured it with YAST/wicked before).

But aren’t you using NetworkManager? That has its own configuration tool. You have to make a choice about using wicked or using NM (via YaST > Network Settings)

Yes, I am. Used wicked because I lost wlan and couldn’t find nm configuration tool. I used wicked only once to change to DHCP and to make wifi password saved to the configuration. Then I switched back instantly to nm (with wicked wlan didn’t work neither).

So I’m going back to my very first posting in this thread : how can I make a diagnosys of wlan network with Network Manager and try to make changes in order to no more loose wlan after reboot ? As I said, I’m forced to uninstall broadcom, reboot, install broadcom again and reboot again each time, which makes my HP MINI unusable by my son as I don’t have ethernet in my son’s room.

I’ve found this link in broadcom website : http://www.broadcom.com/docs/linux_sta/README_6.30.223.271.txt
Well, my driver is from packman (broadcom-wl packages), so I didn’t followed the instruction as broadcom-wl is functional in my HP MINI untill reboot.

I understood that it is normal to have loaded lib80211 first, then cfg80211 and wl :

modprobe lib80211
modprobe cfg80211
insmod wl

But, I had only two of them :

lsmod | grep wl
wl                 6376401    0
cfg80211         547052   1   wl

Maybe I should do “modprobe lib80211” with a shell on the boot, before loading wifi ?
If so, could you please explain me how to ?

Also, right-click on the icon of wifi connection (on the right-bottom) gave me a screen showing Network Management Configuration, maybe it is the plasma-nm I was looking for ?
Notification in there showed also that it failed to activate connection because VPN module was missing, I wonder what does it mean ?

How are you managing to reactivate the wireless following boot? Or does it remain inactive/disabled?

Following a reboot, examine the output of the following

/sbin/ifconfig
/usr/sbin/iwconfig
nmcli g
nmcli d

Capture the output to a text file, and post here once you have the wireless device active, or transfer to an internet connected machine via memory stick and post from there.