newbie problem with installing torrent clients *sorry*

Hey guys!

I just switched to Linux and I’m still not so familiar with the console commands, so I use mainly YaST to install new software, which worked fine until I tried to download a new torrent-client (ktorrent kind of sux) and I always get this error message during installation/ downloading:

Subprocess failed. Error: RPM failed: error: open of /var/cache/zypp/packages/openSUSE failed: No such file or directory
error: open of 11.1-0/suse/i586/ktorrent-lang-3.1.5-1.19.i586.rpm failed: No such file or directory

So I know this might be ridiculously easy to solve, but I still have no clue :frowning:

Thank’s in advance!:slight_smile:

If i’m not wrong that’s because you have DVD setup as a repository and You haven’t got the DVD in the drive? It’s best to leave the iso image somewhere on the disk and set it as a repo (only DVD image of course).

Check if you have the DVD set as repo (should say something like /dev/sr0 ) in software repositories in YaST.

Ah! if I check software repositories → repositories there is no local path like /dev/… only ftp and http sources… I also used the Online-Installation method were it downloaded all the data during installation (took like 5 hours ).
So what do do now? should I download the full iso file?? Is there any other way to get those missing files? :|:|:|


Maybe go to software repositories and refresh them all?

I did…still no sign of it and installation isn’t working either (same error occurs)…:frowning:
****! I had to reinstalled the system yesterday again, because I couldn’t get this graphic card problem fixed,don’t wanna do it again… Isn’t there any chance of getting those missing files?

Thanks again!

You can always download it with a web browser from the repo?

Ktorrent is actually one of the best if not the best, doesn’t take much memory, has support for ip blocking and encrypting packet headers, has a scheduler, doesn’t take much memory.
For gnome transmission is good but i have bad experience with it (lost about 8GB of data)

Mhhh…okay…But the thing with ktorrent is, that it won’t start downloading!Whenever I import a torrent, it always stays on “Stopped” even if I click on “resume”… tried messing around with the configuration…didn’t help >:(

Hmmm, i never had problems like this. Could you tell me what desktop environment You got (KDE, GNOME), what version, what repos You use (zypper lr as sudo).

I use the latest KDE (used gnome before which didn’t work out because of my gc)

#  | Alias                            | Name                             | Enabled | Refresh
1  | Main Repository (NON-OSS)        | Main Repository (NON-OSS)        | Yes   | Yes
2  | Main Repository (OSS)            | Main Repository (OSS)            | Yes   | Yes
3  | Packman Repository               | Packman Repository               | Yes   | Yes
4  | VideoLan Repository              | VideoLan Repository              | Yes   | Yes
5  | home:jefferyfernandez:playground | home:jefferyfernandez:playground | Yes   | Yes
6  | openSUSE 11.1-0                  | openSUSE 11.1-0                  | Yes   | Yes
7  | repo-debug                       | openSUSE-11.1-Debug              | No   | Yes
8  | repo-non-oss                     | openSUSE-11.1-Non-Oss            | Yes   | Yes
9  | repo-source                      | openSUSE-11.1-Source             | No   | Yes
10 | repo-update                      | openSUSE-11.1-Update             | Yes   | Yes

Ok, disable repo number 4 and 6. From repo #4 you only need libdvdcss for playing DVD’s. Repo #6 looks to me like a DVD drive repo so disable it. After that go to Software Management, change to repositories look, go to packman and update unconditionally. That should do it.

I recommend You to use KDE 4.2 which is said to be more stable than the one supplied by 11.1