Newbee Question - Probaly very simple

Got a question about Yast2.

I want to install a few programs but Yast2 is prevented from starting by another program. When I am trying to start the program is partially visible in the top left corner an states the following message in about 10’.

Systeembeheer is geblokkeerd door de applicatie met pid 4280 (/usr/lib/YaST2/bin/y2base).
Deze applicatie afsluiten alvorens opnieuw te proberen.

Systemcontrol is blocked by the application with pid 4280 (/usr/lib/YaST2/bin/y2base).
Close the apllication before continue.

I’m running OpenSUSE 11.1 Gnome on a new Asus N10j netbook.
OpenSUSE is the only partition.

I’m tryin to cope with linux after my PSR action to stop using MS. Please help me!

Did you check if the process wth pid 4280 runs. And when yes, did you try to kill it?

Also log out will possibly remove the prcocess.

And of course a reboot will kill all processes including 4280.

Thanks for your quick answer.

I’ve killed the program by rebooting. but…
On restart of the software installer, it flies directly to the top left corner of my screen where none of the info is visible.
I can drag the thing down a bit… The program is downloading info from but stops automaticly after about 20’.

I thought the leftopcorner flight might have been caused by bad screen settings but when checking, everything looks allright.

You first said that YaST was not starting. You now tell that Software Management is starting (albeit doing strange things). But when you have Sofware Management running, YaST must start first.

Am I correct in that YaST at least starts normally (after asking for the root password) and that those windows are OK?
Then you click Sofware Management and this starts and then does the things you describe?

Do other windows also do strange things?

And another remark for the future. Do not call your question: “Newbee Question - Probaly very simple”, but something like: “YaST does not start, complaining about a process”. It is much more descriptive about what your problem is and it will problably lure the right people to read your thread.

Ok cheers, will be more clear in the future about forum titles and the message.

You are abslolutely right about the situation.
Other utils are doing the same. like the local security manager…

many thanks

So we can now suppose it is something with your screendriver/X/windowmanager or the like. Now I am not very good at this. I jumped into your thread because of the pid error.

As fellow dutchman, I do the suggestion that you start a new thread with a new title about the problem that your windows do strange. When possible do not use YaST as an example, but e.g. FireFox or another ‘simple’ very much used application. Add data about your graphics card and driver if you know them. You could also try to make an image from what happens and attach that.



The lefttop screen is solved. Seemes the laptop has a Nvidia 9 series card on board. I ran the link from the site and the YaST manager started to work.
After the installation of the Nvidia drivers, i tried to start up the software manager again… which started without any problem whatsoever…
It’s good that the problem is solved but a bit of a ***** that i don’t know why…

Anyway… Veel dank…


I’ve noticed behaviour very similar to what you describe and I think it might be the same. YaST always starts by opening the YaST control centre in a window at top left of the desktop with sets of PC areas listed for performing various tasks such as Software, Hardware, Network etc. Selecting one on the left offers various modules for that section of the PC. Software offers repositories, package management, auto update etc.

If the machine is configured for auto update (little green gecko showing in bottom right system area) then it is already using a module in the software management set and I found I could only get YaST2’s software management modules to work if I did a right click on that icon and selected “quit”.The applet restarts next time you re-boot so it is not a problem. After closing the auto update I could start other YaST2 modules.

I believe Y2base is the first window with the menus and YaST2 is the GUI that starts when a particular module has been selected. That may not be precise but seems to fit with what I’ve observed on my system.

All of this may not be the issue you are seeing but it’s worth giving it a try.

Groeten uit Engeland. DC :slight_smile:

This is a fairly common affliction - happened to me as well. The simple, inelegant solution is to open a terminal, then type

su -
kill [number of process]

Then try to rerun the software update. It might take a few tries, but it’ll work in the end.

Nu beginnen we ineens allemaal nederlands te tikken. Is wel leuk.

Nice your problem is solved. Hope you like openSUSE.