Newbee and the Atheros 5007

This week I had an course about Suse, I never had worked on a Linux machine only Windows. After the course I was pretty impressed by the possibilities that Suse has, and thought by myself I give it a chance and install it on my notebook(Acer Aspire 7720Z). After installing the only thing that wasn’t working was the Wire Network Card, the Atheros 5007. I looked on the internet and found a lot of help, first tried to follow the steps that where provided by and installed a tar bal. After doing exactly what was written, it still didn’t work. Then I found an page here on the opensuse site and again followed and did exactly what was written, but again no luck, still doesn’t work. It is a bit disappointing when, after about 8 hours trying, that I’m still not able to connect through a WLAN. In installed dozens of windows machines, and there can be some trouble to get it right, but I always manage within an hour or so to get it right. Now with the Suse OS I’m not able to get it right, I know I’m a newbee and don’t understand everything yet, but I’m pretty disappointed by the fact that even after following precise steps, provided on this site, it is still impossible to get the WLAN working. (I dis use this link is there another way of getting this network catd to work (my LAN card is working normally with Suse)

I’m sorry I can’t be of any help, as I only have experience with Belkin and Broadcom cards, which get installed with a different method (using ndiswrapper and WinXP drivers). Someone with an Atheros chipset will chime in eventually. I only wished to say that I’m a newbie myself and was just as frustrated with linux and SuSE at first as you must be now. The point is, we dismiss too easily all the years (or maybe even decades) we spent in Windows, and are prone to forget that Windows was just as frustrating in the beginning (with all those *.ini files to edit, remember?), with that exact same feeling of not knowing where to turn. I can only say that it gets easier with time. Really. Of course, linux per se is a little harder to learn than Windows, but in the end, you get the same end results and the same - actually, even a greater - satisfaction of a job well done.
Cheers and good luck!

I had similar problems with an Atheros card, and I’m also a linux n00b.

I got mine working after a few hours of tinkering… from what I remember, you need the following packages installed before you start:


You then need to blacklist ath5k. I used an editor as root, but I think you can just, as root, do:

echo "blacklist ath5k" /etc/modprobe.d/blacklist

Then you need to install the latest snapshot from here: madwifi-hal-

you may need to uninstall madwifi first (I did, but I’m not sure whether it was necessary).

once that’s done, just do:

modprobe ath_pci

Spent hours trying to make sense of what to do, but the above worked for me.

Thank you for the response, still trying to complete the installation. Did everything what I have read on several threats but it’s still not working.