New version linux set mono microphone to stereo, but do not work in any distribution linux


I try many tips and do not work nothing correctly. I using Lenovo G50-45 with one microphone. I found out through the forums that the microphone track had to be split and one channel muted. Then it works, but during a call such as it returns to its original position and the microphone does not work again. Old Pulseaudio works well maybe new pulseaudio damage microphone settings.

How set microphone pernamently to mono, please.

Manufacturer: LENOVO
Product Name: 80E3
Product Version: Lenovo G50-45
Firmware Version: A2CN40WW(V2.08)
System SKU: LENOVO_MT_80E3_BU_idea_FM_Lenovo G50-45
Board Vendor: LENOVO
Board Name: Lancer 5B2

HDA ATI HDMI at 0xf0d60000 irq 45
1 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xf0d64000 irq 46

When in the “” call, did you attempt to run pavucontrol (pulse audio volume control) and adjust the mic with that volume control ? You may need to install ‘pavucontrol’ if not yet installed.

I have NEVER used “” app myself, so if the issue is a problem with that app, then I can not be of assistance.

This bug make new version PulseAudio. A month ago, everything went ok. Now Linux Mint 20.1, Kubuntu 20.4.1 and other make the same thing.

I try pavucontrol and make the same thing. Try help page arch and create resample to mono but without success.

Try Zoom and seem good. google meet in chrome adjust microphone automatic. Therefore, the channels are reconnected and the sound from the mic does not work.

I would need advice on how to restore the original settings when there was only one channel for the microphone when it is mono and not stereo.

Eu tenho esse mesmo problema com meu Lenovo. Você precisa se reunir com frequência, a negócios.
No meu caso, uso um heatset e funciona para mim.
Mas há outra solução, que ainda não coloquei em prática, quem sabe você não pode fazer isso …

See this video

Thanks I will try next day I using this Arch help before but do not find right combination. I’m sorry the working thing was broken.

Maybe mix microphone from HDMI ?

I found solution.

I tried this tutorial for the first time, but it didn’t work. Then I tried it a second time and noticed that I hadn’t set the correct channel. The second is broken and OpenSuse, Ubuntu and other OS prefer it. I rested. Good luck to you.