New to VNC, need some help

OK, well I’ve read ovr a good amount and can not figure this out. So I am hoping for some help and am going to give you as much information as I can in hopes someone can help! Thanks in advance.

Ok, so I am trying to set up a VNC, but some reason I can not connect to it. In the terminal window I have started a vncserver. It is vncserver: 2. To verify that it was up and running, I do this

# lsof -i -n -P
gdm       1289  root    7u  IPv6   6850      0t0  UDP *:177 
rpcbind   1437  root    6u  IPv4   7461      0t0  UDP *:111 
rpcbind   1437  root    7u  IPv4   7465      0t0  UDP *:759 
rpcbind   1437  root    8u  IPv4   7466      0t0  TCP *:111 (LISTEN)
rpcbind   1437  root    9u  IPv6   7468      0t0  UDP *:111 
rpcbind   1437  root   10u  IPv6   7470      0t0  UDP *:759 
rpcbind   1437  root   11u  IPv6   7471      0t0  TCP *:111 (LISTEN)
avahi-dae 1673 avahi   13u  IPv4   8161      0t0  UDP *:5353 
avahi-dae 1673 avahi   14u  IPv4   8162      0t0  UDP *:55478 
cupsd     1744  root    4u  IPv6   8776      0t0  TCP ::1]:631 (LISTEN)
cupsd     1744  root    6u  IPv4   8777      0t0  TCP (LISTEN)
cupsd     1744  root    8u  IPv4   8780      0t0  UDP *:631 
master    1816  root   12u  IPv4  10014      0t0  TCP *:25 (LISTEN)
master    1816  root   13u  IPv6  10016      0t0  TCP *:25 (LISTEN)
dhclient  2457  root    5w  IPv4  17113      0t0  UDP *:68 
Xvnc      7469  root    0u  IPv6  36064      0t0  TCP *:6002 (LISTEN)
Xvnc      7469  root    1u  IPv4  36065      0t0  TCP *:6002 (LISTEN)
Xvnc      7469  root    6u  IPv4  36071      0t0  TCP *:5902 (LISTEN)
Xvnc      7469  root    7u  IPv4  36072      0t0  TCP *:5802 (LISTEN)

So clearly we can see ID 7496 is an XVNC server at port 5902.

Well heres my problem, I can not connect to it. I have gone to GoToMyVNC Homepage and here are my results

Checking you out at IP address ##### .... 

##### is not responding on Display 0.

#####  is not responding on Display 1.

##### is not responding on Display 2.

##### is not responding on Display 3.

##### is not responding on Display 4.

##### is not responding on Display 5.

##### is not responding on Display 6.

##### is not responding on Display 7.

##### is not responding on Display 8.

##### is not responding on Display 9.

Scan of ##### is complete.

Hit 'reload' or 'refresh' in your browser to scan again.

So why can I not see this connection if it is clearly started on my machine?

A little bit of other info that may be needed:
I have gone to my firewall settings and allowed ports 5900-5910 on VNC and VNC Server. Also I have allowed remote connection through Yast as well. What is left to do?


try on 5802 port

if it can help…


Also just added 5801 5802 5803… still no luck

Can you post some more diagnostic information: please run these commands and post the results back here:

  • To check the firewall:
sudo /sbin/rcSuSEfirewall2 status
  • To check the firewall ports:
grep CONFIGURATIONS_EXT= /etc/sysconfig/SuSEfirewall2
  • To check the software you installed:
rpm -qa | egrep "VNC|vnc"
  • To check your desktop selection:
cat /home/james/.vnc/xstartup

(use your username instead of james)

and two more things:

  • what is the exact terminal command you use to start a vncserver session
  • are you using Gnome or KDE?

The temrinal command I am using to start is just vncserver :1.

I am on GNOME.

linux-a8kh:~ # /sbin/rcSuSEfirewall2 status
Checking the status of SuSEfirewall2                              running
linux-a8kh:~ # grep CONFIGUATIONS_EXT= /etc/sysconfig/SuSEfirewall2
linux-a8kh:~ # rpm -qa | egrep "VNC|vnc"
linux-a8kh:~ # /home/Geoff/.vnc/xstartup
xrdb: No such file or directory
xrdb: can't open file '/root/.Xresources'
/home/Geoff/.vnc/xstartup: line 5: vncconfig: command not found
linux-a8kh:~ # xauth:  creating new authority file /root/.serverauth.25745

Fatal server error:
Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.

Please consult the The X.Org Foundation support 
 for help. 

I did not type this linux-a8kh:~ # xauth: creating new authority file
It just typed the command above it that you asked and the rest came out. Also another teminal window pops up that says “Desktp (as superuser)”.


Turn off this application that you set (Yast → Network Services → Remote Administration) Quote: “Also I have allowed remote connection through Yast as well”. You’re running something else.

After you do that, reboot to kill any running xinetd desktops. After the boot run this command to clear any old lock files (suggested by X0-lock):

sudo rm /tmp/.X*-l*

Regarding ports:
you ran this: grep CONFIGUATIONS_EXT= /etc/sysconfig/SuSEfirewall2
try this: grep CONFIGURATIONS_EXT= /etc/sysconfig/SuSEfirewall2
But before you do, goto Yast firewall → allowed services and add “VNC” and “VNC mini-HTTP server”. Leave the service called “VNC Server” out (there’s no literature on this massively confusing issue)

Regarding software: I found that installing RPM tightvnc dragged in the RPM LibVNCServer, which you don’t have. But maybe Gnome doesn’t need that. Also I’m using 64 bit ATM and you’re not. Try installing LibVNCServer too.

Regarding my fourth dot point: this time I made the typo (it’s fixed now). So run this corrected command instead:

cat /home/Geoff/.vnc/xstartup

Regarding the terminal command: use this one:

dbus-launch vncserver :1

Finally, also please describe what you did to forward outside packets through your router to the openSUSE server.

You can test the internal working by viewing the VNC desktop from within the server machine. Install the viewer RPM (vncviewer). Then find out the IP address of your network interface with this command


Then run this command to connect to the VNC desktop (if it’s running OK):


of course, you change the to match your IP and you change the :1 to match the value you used when starting VNC server.

Reference: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

linux-a8kh:~ # grep CONFIGURATIONS_EXT= /etc/sysconfig/SuSEfirewall2
FW_CONFIGURATIONS_EXT="vnc-httpd vnc-server"
linux-a8kh:~ # cat /home/Geoff/.vnc/xstartup

xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
startx &

I haven’t done anything to foward packets. I did everything you said and was able to connect. However, this is just on my local machine I assume as it is still not seeing my connection on And it starts an X server with just a terminal. Is there anyway to start the entire GNOME desktop?

Hi again.

Regarding these two services in the Yast firewall settings: vnc-httpd vnc-server. Please take out the service “vnc-server” and in its place put the service “vnc”.

To get a full Gnome Desktop, change the contents of the file xstartup. Edit the contents to be like this:

/usr/bin/gnome &
##xrdb $HOME/.Xresources
##xsetroot -solid grey
##vncconfig -iconic &
##xterm -geometry 80x24+10+10 -ls -title “$VNCDESKTOP ##Desktop” &
##startx &

[FYI the ## makes the lines ineffective but preserves them in case you need to revert at some later date]

That should get you a Gnome Desktop.

To get in from the outside on, you need to enter your router and forward the appropriate port or ports (5900 most likely, or 5900-5910, or as you wish) to the IP address of your computer. It might be necessary to use a fixed IP for your computer if you have a LAN of several PCs all using dynamic addressing (DHCP).

I added it just as you said but still am getting th same grey background with terminal.

linux-a8kh:/home/Geoff # cat /home/Geoff/.vnc/xstartup

##xrdb $HOME/.Xresources
##xsetroot -solid grey
##vncconfig -iconic &
##xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
##gnome-session &

See the image below for what is coming up.

Try this /usr/bin/gnome &
instead of /usr/bin/gnome&

Just changed it, but I am still getting the same thing. Any other ideas?

By the way, thank you so much for all your help. You have gotten my VNC up and running well enough and I appritiate that a great deal. The only thing left for me to figure out is how to start the gnome desktop

Way back when, the gnome desktop worked for me. It’s uninstalled now. All I can do is install Gnome and double check what makes Gnome work. But that will take some days.

OK Gnome desktop works for me as described earlier. So please do three things:

run the command: vncserver -kill :1 (space between l and :1)
reboot the computer
run the command: dbus-launch vncserver
wait 20 seconds
run the command vncviewer

What happens? If it doesn’t work we’ll need to check things one by one.