New (to me) Radeon Pro WX7100 fails on HP Z640 with 6 red light flashing

So much for my just arrived WX7100 delivered this evening. Sadly no video and just 6 red light flashes and beeps.
I have re-seated the card but same result.
No access to try the HP diagnostics so will do some reading tomorrow and replace card with the old Nvidia, which worked.
If anybody has experience with this HP workstation or similar and have any tips please advise.

@Budgie2 Did you plug in the power to the card from the power supply? Did you check there is a front fan?

Put you nvidia card back in and check the BIOS Slot settings to make sure it’s on auto…

You can always put the AMD card in the lower slot with the nvidia in the upper?

@Budgie2 The beep code is for not finding a VGA Compatible Device… (Page 101 of the service manual…) The 440 and 640 are the same… :wink:

Duh!!! I omitted the power supply lead which I have never used before. Found it neatly stored behind the front fan.
Now up and running but will have to take it all down and give it a good blow as much more dust than I expected.
Thanks again.

My new AMD card is working well (now I have plugged in the power supply,) but I had some issues with my display. I found I had to switch to Plasma Wayland, which also is working without any issues but, during a recent zypper dup I see that there are several NVidia files requiring update.

It seems that there are residual nvidia apps being called during startup which I no longer need and may be causing the problem with X11 desktop.

How do I clean out all the unwanted nvidia infrastructure please?

As you don’t show any relevant data…just a wild guess: maybe uninstall the Nvidia packages which require an update?

Too vague! Don’t leave us to speculate.

This is the best indication of the problem:-

alastair@HP-Z640-1:~> sudo zypper dup
[sudo] password for root: 
Refreshing service 'NVIDIA'.
Refreshing service 'openSUSE'.
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...

The following 8 packages are going to be upgraded:
  libquicktime0 nvidia-computeG05 nvidia-computeG05-32bit nvidia-gfxG05-kmp-default nvidia-glG05 nvidia-glG05-32bit x11-video-nvidiaG05

8 packages to upgrade.
Overall download size: 272.7 MiB. Already cached: 0 B. After the operation, additional 25.0 B will be used.
Continue? [y/n/v/...? shows all options] (y): 

It is the service NVIDIA which was my initial concern but all the issues are shown here.

This “Service” refreshes the Nvidia repository. So simply uninstall the named Nvidia packages and after that you can remove the Nvidia repository.


As you didn’t describe how you did the exchange of the GPUs, it is logical that all Nvidia packages are still present if you didn’t uninstall them…

1 Like

Hi and thanks. All I did was swap out the cards so this all makes sense as the new card was auto-detected and installed. No action from me until now on removing the Nvidia stuff so many thanks.

There were a couple of openSUSE related nvidia files and only after I had removed these did I get rid of the
service NVIDIA line in the zypped dup but now it is all clear. Thanks again for your help.