New to Linux and have a few problems

I’m new to linux and despite most things working pretty well for me, I am having two issues that I can’t seem to resolve. Hopefully someone here can point me in the right direction:

System Info
Operating System: openSUSE Tumbleweed 20230813
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.108.0
Qt Version: 5.15.10
Kernel Version: 6.4.9-1-default (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics
Memory: 9.6 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: LENOVO
Product Name: 82RN
System Version: IdeaPad 3 15ABA7

Bluetooth Mouse

I am trying to use a bluetooth mouse with computer and although it’s connected, it’s so laggy and stuttery, it’s essentially unusable. Here’s a recording of me trying to move the mouse in slow, gentle loops:

I have tried setting the min/max interval settings for the mouse in /var/lib/bluetooth/<ADAPTER_ID>/<DEVICE_ID>/info without seeing any difference. I don’t have another bluetooth mouse to try, but I have tried this mouse with other (Windows) computers to make sure it’s working properly.

External Monitor Resolution

The laptop I am on has a 1080p monitor. If I connect a 1440p external monitor ( LG UltraGear), it detects the monitor and displays on it, but detects a resolution of 3840x2160 and no matter how many times I’ve tried to lower the resolution to 2560x1440, it refuses to honor that change.

Do you have any other bluetooth devices that you can test?

For me, a bluetooth mouse works well. But a wireless mouse (not bluetooth) is laggy. That seems to be a wireless reception problem. Wireless mouse (and bluetooth mouse) use a fairly short wave length, which can reflect of small objects such as a screwdriver in my desk drawer. This leads to the distortion of multi-path reception.

For my wireless mouse, I tried plugging the nano-receiver in a USB port at that back. And that was very laggy. So I switched to a USB port on the front. That was better, but still laggy. So I tried moving my computer tower (pushed it back around 2 inches), and now it seems to be pretty good. Maybe some adjusting of the wireless transmission path can also help in your case.

Sorry, can’t help with the monitor issue. I’m not experienced with that problem.


In your screenshot you have the smaller monitor selected. If you click the larger monitor, change the resolution to the desired resolution, click Apply and reboot does that setting stick after the reboot?

Before anything else I would log out of Plasma, remove the content from your regular user’s ~/.cache/, connect and turn on the second display, then login to Plasma. If if works, I’d go into display setup and check the box to remember for the specific display arrangement.

Next would be to create a new/virgin user to login and ensure it’s a system-wide problem and not just your normal user’s problem.

You may try disabling Plasma display control and instead use xrandr script(s) to handle display switching. In systemsettings5 (whatever the menu calls it lately, maybe personal settings or desktop settings) there is a section for background apps auto-starting. There disable KScreen2 to wrest control from Plasma. You can generate xrandr scripts manually and attach to hotkeys, or with less work install and use arandr to generate needed script(s).

Months ago upstream KDE announced that 5.27.x was expected to be greatly improved in multiple display handling, but I think it was much too optimistic given the number of bugs that had been and are still being reported.

I just tried a pair of bluetooth headphones, but they were just as bad. Basically the audio version of the mouse jumping around. I even tried moving to a completely different location to different location in the house with no difference to either problem.

That didn’t make any difference.

I will have to give that a try, but this issue has persisted across a complete wipe of the system. I’ll still give it a shot, though. It’s not like I have anything to lose :slight_smile:

Bluetooth headphones are working well here.

From your description, it seems that you may have a poor bluetooth implementation on your computer.

I am reasonably sure then this is no hardware problem, the problem is that the wireless connection is bad.

Bluetooth shares the medium with WiFi and several other protocols and for experience I know Bluetooth and WiFi do not work too nice together.

For work I develop WiFi but at home my mouse and Internet connection are wired :wink:

For the monitor: Does your video card support 3840x2160? You can check using “xrandr -q”

I have an ~8 year old computer and that supports maximum 2560x1440

Since my last update, I have tried reformatting with Windows 11 (as a baseline), Ubuntu 23.04, and Linux Mint 21.2. The bluetooth works great with all of them. EndeavorOS behaves like openSUSE. I’m not sure if Ubuntu uses a different bluetooth package or not or even how I would tell, but the fact that they’re handling things well indicates that the problem isn’t hardware or connectivity based. At least that’s not the only component.

It’s using the integrated graphics on the CPU which does appear to have a max resolution of 3840x2160. All of the Linux distros handled the monitor resolution poorly, though. Some of them refused to change resolution while others “changed the resolution” by setting the desktop size to 2560x1440 and drawing a 1280px wide x 720px tall border on the right/bottom. I’m disappointed in the monitor thing, but I can live without it for now.

That is a good data point.

I would verbose dump the configuration and version information and diff them to find hints of what might be wrong. The problem is that I do not really know how to do that, it that is possible (btmgmt extinfo) but I tried to get btmgmt working but di not manage to do that yet.

On the display you wrote that all of the Linux distros handled the monitor resolution poorly, I assume that it works fine on Windows. If so, this problem might solve it self over time, newer hardware support on Linux typically takes time. You can speed things up reporting these problems and providing help testing things.