New PPC G4 Install No Sound

My Suse 10.3 install on my all Apple, G4, Digital Audio Mac went smoothly except I have no audio. I don’t think my video works either, but I’ve concentrated on the audio for the past few days. Knowing little about getting the audio going I checked the forums/etc and this is what I have so far.

My initial desktop had a normal volume icon, but my tests with the Yast control sound showed no sound when tested. My exploration of the forums said to try to run the Alsaconf script. I did and got no sound still, but now the volume control had a red X through it. I also went to the Yast config tool and tried to configure my sound (my G4 has onboard sound and is termed Powermac Tumbler), but I got an error message using the normal configuration setting which read “The kernel module snd-powermac support could not be loaded… invalid IO or IRQ parameters”.

I discovered SDB and the page SDB:Audio Troubleshooting. I executed the two scripts and the results are: Alsa info: 1050185 tsals: au5Pvd4E1 stored on the server.

My Alsa packages installed are alsa (1.0.14-31.2) alsa-utils (1.0.14-27) and alsa-firmware (1.0.14-24)

No pulse packages installed according to rpm.

I wanted to update the alsa packages, but all the sources cited were for i386, i586, and 64bit Intel.

BTW, my 0.10 gstreamer directory is full of .ko files. I could be missing one, but I wouldn’t know how to figure that out.

I’m trying to fix this myself, but I’m over my head here and would appreciate any help I could get. I hope I have enough info above and that I’ve posted my message in the correct forum.

Since no one is replying, I’ll just add additional info that I’ve found since posting this in the hopes that someone reading the thread and having my problem will get something out of this.

My kernel has been updated. new =

Results of running Yast hardware listing yields this:

14: None 00.0: 0401 Multimedia audio controller
[Created at prom.336]
Unique ID: rdCR.ITz6G5CcwPB
Hardware Class: sound
Model: “Apple Integrated Sound (awacs)”
Vendor: int 0x0401 “Apple”
Device: int 0x0010 “Integrated Sound (awacs)”
Driver Info #0:
Driver Status: snd-powermac is not active
Driver Activation Cmd: “modprobe snd-powermac”
Config Status: cfg=yes, avail=yes, need=no, active=unknown

/proc/asound/oss/sndstat says:

Card config:
PowerMac Tumbler (Dev 14) Sub-frame 0
Audio devices:
0: PowerMac Tumbler
31: system timer
0: PowerMac Tumbler

If I attempt to configure the sound card that’s listed in the Yast config window, Yast quits. If I try to config the awacs file in the config window, Yast tells me to go pound sand. Deleting the other card and trying again gets the same result.

At first boot lsmod does not list snd-powermac module loaded. Doing a modprobe snd-powermac loads module, but still no sound.

SND_POWERMAC needs to be loaded at boot and I’ll figure out how to do that, but that still won’t solve the audio problem. One step at a time, I guess.:slight_smile:

I’ll take a stab at this … even though I don’t have a Mac.

Can you try work your way through the audio troubleshooting guide. It was clearly not written for a Mac (but was written for a i386, i586, and 64bit Intel architecture) but it still might be helpful (for example the rpm updates don’t apply to your Mac).
openSUSE Audio Troubleshooting

In particular please post here the URL(s) that is output by your running the two diagnostic scripts:

And also paste here the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I hope to learn what audio hardware codec your mac has. It might be necessary to do a custom compile of alsa, but no worries, … we can cross that bridge if and when we come to it.

Please read my first portion of the thread. All of that info you need is there. I put that in at the first after spending several days reading the SDB troubleshooting page, etc. My second portion was additional information I gained just going from directory to directory looking for anything related to sound.I’ve also been to the ALSA web site looking for information also. I’ve done several installations on both PPC and Windows machines and sound is always a pain. I have never had problems with sound either on a Mac or in Windows using their OS’s only with Linux have I had problems. I know ALSA is trying hard to make sound universal like printing is with CUPS, but it still needs some tweeking. I’m patient, I’ll wait. It will get there eventually.

Please note that my kernel was updated and that part on the ALSA info will be different. Try also 1052518 with the new revision.

I actually read your post a few times before I replied. I do not see your hardware audio codec there. Maybe its because I am not familiar with a Mac. … or maybe its not there.

I asked for the output of “rpm -qa | grep alsa” because I want to see all alsa apps you might have installed, not just the ones you want to tell me about.

I asked for libasound2 because I know of cases where users did not have that installed and it broke their audio. You did not mention that.

I asked for the “uname -a” because in the past, I have been helping users who would change their kernel in the middle of support and not tell me. I want a constant baseline and typing “uname -a” does not hurt.

I asked for the output of “cat /etc/modprobe.d/sound” because I know of at least one case, where I helped a Mac user with their sound, that that file needed a hand edit for mac users.

The diagnostic scripts also provide an assortment of useful mixer information, that might point to a bad mixer setting.

You know, if this help from me is going to work, you will have to trust me and provide information I ask for. If you cant’ do that, well no worries, … maybe someone else will chime in.

Good luck.

I’m sorry if I wasn’t complete in my first portion of the thread. Out of rpm -qa | grep alsa:


rpm -qa | grep pulse
My kernel: Linux Tuxland #1 2008-06-09 13:53:20 +0200 ppc ppc ppc GNU/Linux

alias snd-card-0 snd-powermac
alias sound-slot-0 snd-powermac

Liba: libasound2-1.0.14-31.2

I tried like crazy to figure out the codec part, but my audio is onboard and is the Powermac Tumbler/Awacs info that I gave earlier. Reading the SDB guide I was still unable to gleem out anything useful (on a codec) because I don’t have one of the common sound cards. I’m sorry if I can’t be of any help here. I hope the hardware info given by Yast is useful. I kept seeing it, every time I opened up another file or directory in my searching. Please let me know if you need anything else and BTW, I think your explanation above for why you need the info is very useful for others reading this thread and who are trying to understand how the sound system is supposed to work. Specific fixes to specific hardware usually leaves people wondering how the fix fitted into the overall scheme of things for sound in Linux.

Typically this (finding out the hardware audio codec) can be the trickiest part. Sometimes:
cat /proc/asound/cards
will show the codec, but more than 50% of the time it will not.

But the diagnostic scripts are very good at providing the codec. Hence it would really help if you can download the scripts tsalsa and to your hard drive. Then from a terminal/xterm/konsole run with: bash

And from a terminal/xterm/konsole (with root permissions) run tsalsa with: bash tsalsa

Those scripts will post a bunch of info about your Mac, … on the mixer settings, and also give the codec that I really need. They will paste that info to a URL that you can then pass to me so I can take a look at it.

In the few cases where I helped a Mac user, I was able to take that “codec”, look up in the ALSA-Configuration.txt file what “model” option they needed based on that “codec”, and then apply that “model” option to their /etc/modprobe.d/sound file with very exact syntax, and their sound worked.

I executed the Alsa config sh when I had the old kernel and it is located at 1050185. With the new kernel it has a address of 1052518.

The tsalsa script returned an address of au5Pvd4E1.

I hope that this is what you want. If not, I’ll do it again according to your needs.

I don’t have a Mac either, but:

Go into Yast and add alsa-tools & alsa mixer.

then in a terminal as root do “alsaconf”
accept the defaults

should finish with an opportunity to test
if there is no sound, open “alsamixer” and make sure there is nothing muted:)

Let’s see what happens:rolleyes:

Per snakedriver’s suggestion I looked again at your mixer settings from tsalsa.txt - (beta)

Amixer contents for card 0 [Tumbler] _____________________________________        
amixer set 'Master',0 75%,75% on        
amixer set 'Headphone',0 on        
amixer set 'Headphone Detection',0 on        
amixer set 'Bass',0 Mono: 0 0%        
amixer set 'Treble',0 Mono: 0 0%        
amixer set 'PCM',0 90%        
amixer set 'PC Speaker',0 off        
amixer set 'Auto Mute',0 on        
amixer set 'Beep',0 15%        
amixer set 'DRC',0 on        
amixer set 'DRC Range',0 Mono: 57 60%  

… what is "amixer set ‘Auto Mute’,0 on " ?? Is that a mute? Is it in the correct position?

Failing that, I think you may need to custom compile alsa, as as far as I can see there are no custom edits to the /etc/modprobe.d/sound for the “PPC tumbler” audio hardware. I notice this for updates to the “tumbler”:
Power Mac tumbler updates

Also, I’m curious why you did not post the complete URL from the diagnostic scripts, … it was a bit painful for me to put the URL together for those scripts, when all you had to do was post the complete URL, as opposed to just a “number”.

I take it that you want me in the sound config of Yast. I got there and did an add and got the Manual Sound Card Selector. Choosing Alsa I have for sound card model: Dummy soundcard, Midi serial u16550 and Virtual rawmidi device. Am I in the wrong place?

Also, I ran alsaconf a few days ago and got no sound during the test. I don’t know if this helps, but my volume control right now is connected to the OSS mixer for PowerMac Tumbler. The volume settings are about 75%, but the speaker setting is all the way down and if I set it higher I get a muted condition indicated with a red cross. If you’ve never seen this mixer (I know there are many) it only has three sections: Volume, speaker and PCM-2. The help for this window basically says set the settings and close.

I’m sorry about the pastebin mess up on my part. I just remember from the SDB that the number was important. I have never ever had mixers to deal with before as I’ve always used default settings for everything and only changed the volume as need be. I guess I’ll just go find out about compiling the Alsa tools. Thank you for your help, I’ve learned a lot today.

Typically Gnome users have an application called ‘alsamixer’. If you type that at an xterm/terminal/konsole, I think if you are a gnome user you will be presented with a plethora of settings you can adjust. KDE users have an application called ‘kmix’ that they run.

I confess the application “OSS mixer” does not ring a bell.

If you do have to compile, keep posting here wrt your trials and tribulations and I am confident users will pitch in to help.

I’m away on business for two days starting tomorrow, so I won’t be able to help for a brief interlude.

Since you are going to be compiling a driver, you will need the kernel-source rpm installed for your kernel version. You will also need to install the rpm for the kernel headers known as linux-kernel-headers. You also need to have installed gcc, gcc++, gcc42, gcc42++ and make. I also like to install the application “checkinstall”.

Note when it comes to custom compiling, typically one downloads a compressed archive affectionately known as a “tarball” (with an extension that may be something like application.tar.bz2) to their home directory. Lets say you download it to /home/your-user-name/compilations.

Uncompress that into your home directory, while its in /home/your-user-name/compilations. The tarball when uncompressed should end up in its own subdirectory (perhaps called alsa-driver-1.0.16). You need to open an xterm/konsole and change to that directory with something like: cd /home/your-username/compilations/alsa-driver-1.0.16

Then read the readme.txt and install.txt files. Typically full of very confusing stuff, but sometimes there is something important that registers.

Then compile with something like:
su * #enter root password when prompted*
make install

or alternatively, instead of “make install” type “checkinstall”.

The difference between “checkinstall” and “make install” is “make install” will put the driver/application directly on your hard drive, but there will be NO database tracking of it, and you must ALWAYS keep the compilation directory you made, so you can remove it (with “make uninstall”) if it becomes necessary.

BUT if you instead run “checkinstall”, it will ask for some easy to fill in information (select Y for documentation, and type in some arbitrary words in the description), and when it then executes it will create a custom rpm designed for your PC. After a successful run of “checkinstall” the application/driver will NOT be installed, but instead will be stored in something like /usr/src/packages/RPMS/PPC ?? (I’m guessing for a PPC). You can then copy that rpm to your /home/username directory, and install it with: rpm -Uvh application-precise-name.rpm

… and the new rpm you installed will be tracked by the rpm database.

I always use “checkinstall” (instead of “make install”) but sometimes “checkinstall” doesn’t work. Other times, it will work if one first runs “make install” and then runs “checkinstall”.

Do that for each of alsa-driver, alsa-lib, alsa-firmware (and alsa-utils and alsa-oss, although they are not as important). When done, and the rpms installed (if you used checkinstall) then reboot your PC and test your audio.

I got so frustrated that I did a find on alsamixer.(May the guy who decided not to have a locate command in Suse rot in hell!). Anyway, from the terminal I executed the command “alsamixer” and a funky control panel popped up in the terminal window. I couldn’t control anything, but I decided to do a man alsamixer and I got a man page! The operation of the panel is something out of the days of MSDOS, but I set everything to what I thought would be correct. I did a test using the sound control in the control panel and the sound test produces tone. So much for gui control. :-). Now I’m off to see if Banshee works.

Thanks for the help again. I’ll keep the info on the compiling also, as I’m a radio design engineer and not a software engineer.

this is the output …

No sound, even no icon in YAST


subhan222@linux-70u7:~> rpm -qa | grep alsa
subhan222@linux-70u7:~> rpm -qa | grep pulse
subhan222@linux-70u7:~> rpm -q libasound2
subhan222@linux-70u7:~> uname -a
Linux linux-70u7 #1 SMP 2009-03-31 14:50:44 +0200 i686 i686 i386 GNU/Linux
subhan222@linux-70u7:~> cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Why have you joined someone else’s thread? Why not start your own? Is there something technical that I am supposed to understand about your set up compared to that of someone else’s, which is why you have joined their post? There are hundreds of threads in our forum where users have no sound. Why this thread?

If one has no sound, it is much easier to provide support if one starts a new thread, unless there is something very very specific (not just “no sound” as there are hundreds of users with no sound that we try to help ).

Anyway, back to your problem, thanks for the information. But I need more than that to understand your PC setup. With your PC connected to the internet, please run the following twice:
the first time run it with root permissions. It will ask you if you wish to update, …select YES and update. Then the second time run it as a regular user. It will provide you a URL when it is complete. Please post the URL here. JUST the URL.

With that, and with the information you have already provided, I may be able to make an assessment as to why you have no sound.

Also, what is your test for “no sound” ?? The test sound function in yast is broken for some sound devices (its a known bug). I recommend you try one of the 3 tests noted in the opensuse audio troubleshooting guide: SDB:AudioTroubleshooting - How to Test your sound - openSUSE Do any of these 3 tests (2 in the guide, and one in a link provided in the guide) yield sound ?


sorry to kick in the old thread, i thought my problem is similar.

but if thats the way things work here i will create a new thread. I thought user needs to get benefit from existing thread and discuss a similar issue in one thread is better. but anyway.

i will raise a new one.

answer to the /usr/sbin/

linux-70u7:/home/subhan222 # /usr/sbin/
bash: /usr/sbin/ No such file or directory

thanks for being so nice :wink:

OK, … but I’m struggling to see the similarity … Is it just no sound ? Same hardware?

Maybe the users benefit, but I can’t provide help in that environment. I make too many mistakes when I mix up users. And in truth, I find the users are worse than me. They apply fixes from someone else’s system which are inappropriate, and mess up their systems more. When it comes to tuning one’s audio, I’m not a believer for lumping everything in one impossible to read thread.

BUT, and this is very important, that is JUST ME. Please do continue to post on this thread. Others may chime in and help. … I simply know its not easy for me and I will not.

This does not make sense. Did you re-type that? Copy and paste it instead please. I think you made a typo.

On my openSUSE-11.1, if I type:
oldcpu@athlon:~> whereis
alsa-info: /usr/sbin/
which indicates that script is located in /usr/sbin.

So please, this time, copy and paste: