New openSuse install... issues.

Ok, I just finished installing a fresh install of openSuse on my old Compaq Presario V2600 laptop. The problem is, for some reason, it always boots to the terminal instead of starting x and the gnome desktop environment. I have to manually start x every time with the command startx. Then, after x has been started, the display is an unusually low resolution, and it wont let me change it. I tried running sax2 -r -m 0=vesa but this did not help fix the problem. Help please.

The second problem I am having is that my integrated wireless on the laptop does not work. It is a Broadcom 802.11 b/g WLAN. Please help with this as well (I know I will probably have to use proprietary drivers just like I did in Ubuntu, but I can’t find how to install these drivers under openSuse.)

If you need to know more about the specs of my laptop, here you go:

Make/Model: Compaq/Presario V2600
Processor: AMD Mobile Sempron 3100+
Graphics: ATI Radeon Express 200M
RAM: 512 MB
Operating System(s): Dual Boot between XP Pro and openSuse

The new openSUSE-11.2 is giving some ATI users with legacy hardware fits. What has worked for some is to update some X software and the open source video drivers to a very cutting edge version, that seems to work better with such hardware. Typically the video driver comes with xorg-x11-driver-video rpm.

some openSUSE-11.2 users with “legacy” ATI hardware have found they get better behaviour on openSUSE-11.2 from the open source radeon and radeonhd drivers if they use the updates from the X11 : XOrg repository. That repository is here:

… and the rpms that some of us found gave better behaviour are these apps:

  • mesa
  • xorg-x11-driver-input
  • xorg-x11-driver-video
  • xorg-x11-driver-video-radeonhd
    and possibly ( ? ) others for a 64-bit openSUSE ? … (I tried them on a 32-bit PC). One caution - that tends to be a cutting edge repository, so there is always a risk it will make things worse when a cutting edge release has a bug. Hence I recommend adding the repository, updating those specific applications, and then immediately removing the repository. With the new drivers, you should be able to boot directly to run level 3 (NOT via init 3 but direct by pressing “3” in the grub boot menu) , login and then type “su” to get root permissions and try:
sax2 -r -m 0=radeon

then restart (with “shutdown -r now” ) and test your PC’s boot.

If you need help in how to add such a repository, and how to then install the rpms after the repository is added, please advise.

… edit - I can’t help with the rest (wireless/login hiccup).

Problem is, the repository is useless until I connect to the Internet, and I can’t do that until I have the wireless working. (I live in an apartment complex that provides free wireless, so I don’t have access to the router to plug in via ethernet.

Ok, I got my graphics chip and wifi working. However, I still have to start the x system manually every time I boot by typing startx in the terminal. How do I set the system to start x automatically?