New laptop audio not working


I have a new laptop, and the speakers aren’t working. I have sound when I plug in my headphones, but without them I can’t hear sound.

This is the driver Tumbleweed is using:

 lspci -nnk | grep -A2 Audio

00:1f.3 Audio device [0403]: Intel Corporation Comet Lake PCH cAVS [8086:06c8]
    Subsystem: ASUSTeK Computer Inc. Device [1043:1a8e]
    Kernel driver in use: snd_hda_intel

and the kernel

Linux openSUSE 5.10.4-1-default #1 SMP Wed Dec 30 13:10:15 UTC 2020 (4169c1f) x86_64 x86_64 x86_64 GNU/Linux

Can you help me with this issue?

Thank you in advance,

Install pavucontrol use to see if the speakers are active, Note Pulse Audio is set for each application in the PA control

Also test for sound in Yast - Sound

In pavucontrol speakers are shown as ‘Speakers (Unavailable)’

Sound worked with older kernels. 5.4 or so. What can I do?

I’m not sure … Can you provide more info by running a diagnostic script to give some more info?

ie. in a konsole/xterm as a regular user, with PC connected to the internet, and your sound configured the way you think it should work with speakers, send the following command to run the diagnostic script:


select UPLOAD/SHARE when prompted. If asked to update, don’t update (as it should not be needed at present).

When the script completes it will say something like:

Your ALSA information is located at

Please inform the person helping you.

Please post the here on this forum. We will look at it, and see if we can obtain some ideas from that as to what the problem may be.

Here’s the link:

Thank you very much!

Thanks. This is a puzzle. Your configuration looks correct. I think sound should work.

I checked the HD-Audio-Models.txt for the ALC29x (as your PC has an ALC294) and I could not find an entry that was specific to your Asus module.

I note you are not the only one to have this issue, as I have read of Ubuntu users with the ALC294 having the problem. One solution that works for some Ubuntu users is to force this module option ( asus-zenbook ) although you don’t have a zenbook.

You could try it … ie with root permissions add this line to the end of your /etc/modprobe.d/50-sound.conf file:

options snd-hda-intel model=asus-zenbook

Save that change and reboot. If the file didn’t exist, create it, add the line, and reboot.

If it totally breaks your headset sound, then remove that edit (or the file, as applicable).

I am though dubious that it will work.

Rather than waste time of my speculating and asking you to try a half dozen different speculative things, I recommend you do not waste time, but rather immediately write a bug report on the Tumbleweed 5.10.5-1-default kernel for the ALC294 on your Asus ROG Strix G712LV_G712LV.

There is guidance here for bug reports:

I believe < not sure > you can use your openSUSE forum username and password when logging on to Buzzila.

Its best to write the bug report on the ‘kernel’ as the alsa sound driver comes with the kernel.

Re-run the diagnostic script as below:

/usr/sbin/ --no-upload

and attach the file (where your alsa-information is located), that was created by that script, to your bug report.

This should then get the attention of the openSUSE audio/sound packager, who is also a GNU/Linux sound developer (I believe). i.e. you will then get the best help possible for GNU/Linux for audio.

believe it or not this has worked!

The only thing not working now is the volume. I can mute, or unmute. But it doesn’t matter how loud or silent I setup the volume, it sounds always at the same level.

The file existed (/etc/modprobe.d/50-sound.conf), and had a configuration line inside

# nS1_.wahBWK6TeJ8:Comet Lake PCH cAVS
aka snd-card-0 snd-sof-pci

I have commented that line, pasted the one you suggested, and now it works.
Strange issue. Don’t you think that’s weird?

Thank you very much for your help!

Not being able to tune the volume is not good.

I read on another GNU/Linux forum when researching this issue (Ubuntu ? ) that one user reported this same problem (volume could not be tuned) after adding that “asus-zenbook” entry in the configuration.

Ergo - I believe there is a problem with the alsa sound driver for the Tumbleweed kernel.

I recommend you write a bug report on openSUSE kernel as noted in my previous post. Be certain to describe your problem in that report (plus run the diagnostic script and add the alsa information file BEFORE adding the ‘asus-zenbook’ entry). You could also consider running the script again with that entry in place, to see if the openSUSE packagers could learning anything from the difference. I fear thou such is beyond my competence level.

Note an openSUSE packager will not read a forum thread, so you need to ensure your bug report has the salient facts.

Good luck.