New kernel installation and OpenGL problem

I have an OpenGL problem which I have tried fixing in various ways following responses to various forums on here and the web at large. I have a new openSuSE 11 - although it is older than myself in the Linux world since I only joined some 3-4 weeks ago.
On my machine glxinfo gives this:

robert@linux-1f02:~> glxinfo |grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 945GM 20061017 x86/MMX/SSE2

but when I try to access other machines remotely abaqus via ssh I get this (from two different remote machines):
—machine #1----
$ abaqus cae &
[1] 12443
$ ABAQUS License Manager checked out the following license(s):
“cae” version 6.6 from …
<13 out of 14 licenses remain available>.
libGL error: open DRM failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
ABAQUS Error: ABAQUS/CAE Kernel exited with an error.

-----machine #2------
:~/abaq> abaqus cae &
[1] 25435
:~/abaq> Abaqus License Manager checked out the following license(s):
“cae” version 6.7 from …
<13 out of 14 licenses remain available>.
libGL error: open DRM failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
X Error: code 129 major 129 minor 5: GLXBadContext.

Warning: Your system needs to be reconfigured to allow OpenGL
rendering to a pixmap or Pbuffer; otherwise, you will not be
able to print or use the probe function in Abaqus/CAE.

In the second case abaqus cae actually opens but will not allow me to perform my tasks as it gets into an almost frozen mode!

First I’m not sure if the problem is my machine, but I know that other people have successfully accessed the first machine and run abaqus via putty in windows, although even this won’t work on my windows partition. It gives similar errors to the second machine above. Assuming then that it is my problem I proceeded as below.

At first I played with the xorg.conf file, changed 0660 to 0666 under section DR1, added other lines to the modules section according to other xorg.conf files I had seen on these forums but all these did not change a thing!

Someone mentioned that the problem might be with the way my kernel was compiled, that some (3D) graphics module may behave differently when compiled into the kernel compared to when used as loadable modules. Having roamed the web to find out how to compile kernels I decided to compile a new one to sort the problem out. I was running OpenSuSE-, and OpenSuSE- kernels (I suppose they are the same!). I have now installed kernel 2.6.26 from I specifically selected the direct rendering option during the “xconfig” stage. The new kernel does everything the other two do but I still get the libGL problem.

During the installation I amalgamated instructions from two different sites since none seemed to work completely for me. They were: How to compile and install a new Linux kernel and How to: Compile Linux kernel 2.6. The first suggests stages

make mrproper
make clean

none of which I did as I wasn’t sure what would happen to everything else since I didn’t have backups. (it said mrproper would delete my .config file)

Now my xorg.conf file looks exactly the same in the other versions including the “glx” and other options I had added in the earlier ones. I’m not sure if the relevant modules were thus not compiled into the kernel due to their preexistence as loadable. So I wonder:
Would the “mrproper” stage damage my other kernels?
If not should I try to re-install kernel 2.6.26 utilising these options?
Otherwise, is there any other possibility?
If I reinstall it, I don’t quite want to have an endless list of options at the boot stage when selecting the option I should run (each of the others also has a failsafe version and the default also has a debug version); is there a clean way of removing the current 2.6.26 installation without affecting anything else?

Any ideas will be much appreciated.

PS: I have not posted my xorg.conf file here because I realise I have already made an excessively long post!