New install, pppoe and gcc missing

Hi guys

I installed openSUSE a couple of weeks ago but didn’t use it until 2 days ago. It was the latest version when I installed it.

To my surprise there wasn’t a gcc or pppoe installed. Or at least there wasn’t a command line begging with ppp.
I tried to install them both with rpms. I think I got them both, just they don’t work very well. In particular rp-pppoe doesn’t work at all. It says that there’s no modem on eth0, which is very true there’s only a eth cable. gcc seems to work but I’m not sure I installed all the dependencies.
I can’t use yast because of lack of internet. I have to reboot to windows and download rpms.

Can you give me a work around? At least for the pppoe then it might fix itself. Can I have some EXACT links to rpms or another solution?
I have a 64bit system.

Also sorry if this is in the wrong section or has been discussed before.


IIRC you don’t need rp-pppoe as the required functionality is in ppp already. You might want to install smpppd and/or kppp to control ppp. I don’t use PPP so I can’t be certain of this, just something I remembered when I did once use PPP with a wireless Internet modem (but it worked like a PPP modem) with openSUSE 11.0 or thereabouts.

They are available on the standard distribution DVD so I guess you just missed them.

Try a search on opensuse software search and you will see them.

Like ken_yap said I do not think you need rp-pppoe to make your connection.

You can make the pppoe connection with no modem from yast DSL connections. A tutorial for 11.0 is available here.

My guess is that the necessary packages will come up to be installed when you do the steps in this tutorial.

Making the connection like this won’t use rp-pppoe I think but if you want to control your connection with if-up method, you will be able to do it with **rcpppoe **command.

gcc package is not installed by default IIRC so you will have to select it manually.

So if you still have the DVD put it in, set-up the connection like with the steps in that tutorial (small changes will be necessary, e.g., you will have to add a new “provider”). For gcc change the yast package view or search it to install.

Cheers and good luck.

They should both be in the standard repository.
Yast-Software-software management

This might help if you don’t know the Suse way

Software management - openSUSE

Thanks ghost. That tutorial for pppoe worked.

I still have a few more questions.
The update system doesn’t work. I get the following error:](
It did something, just not sure what. It might be working in a way.

Also I could use help with 2 minor cosmetic issues:
First is the Grub. Where is the file for it?

Second: I have 2 different monitors and each time I boot up I have to set the position for them via the Display Settings.
I have to set the absolute values for the main monitor relative to the second. What file can I edit to do this automatically at startup?

Thanks again