New Install GTK2 not displaying Breeze-Dark theme

I just got a new computer. Installed tumbleweed. Copied my user profile to my new home folder. Using KDE. Everything works great, except apps using gtk2 are not applying the breeze-dark theme. I logged in as root, and have the same issue there. So, not related to my home folder. GTK3 apps appear fine.
The usr/share/themes folders are exactly the same between my old and new computers. All the config files in my profile are the same.

Can anyone offer any advice for me to try to get this working?

NEVER log in in the GUI using root. For testing if another user has the same problem, create another user. Please do not misuse root.

And even if you think that this rule does not apply to you (for whatever reason), then do not publish that here on the forums where innocent people could get the idea that it is normal and secure to use root for other thing then those that really need to be done “as root”.

Gee, thanks for the help. As a 50 year old who has been using unix for the past 35 years, Opensuse for at least 15 years, you’ve really taught me a valuable lesson.
(I was obviously using it for a good reason… The issue is when people use root as their primary user and just do regular things as root… Not all of us are idiots… even when we need help) But just to make you happy, I did just create another user and it too has the same issue.
-Edit just to ask… what do you think people should do when needing to change files their user doesn’t have access to? Just throw the computer away? And what if they are an individual at home w/out an admin? Or maybe they are like me, and that is literally their job title… I have no higher up sitting here to take control and fix things for me… That’s my job. Sometimes you need to be root! And simply logging in as a root user to do a specific task is not wrong!

Back to the topic at hand… Can anyone help figure out why gtk2 is not using the breeze-dark theme? I’m even qualified to log in as root to try things :).
edit again to say, this is a new install, so even if I do log in as root and accidentally install a virus, no big deal. I’ll re-install. BUT, this is a fresh install so the issue will still be there. SO again… can anyone help figure out why on a fresh install, GTK2 apps are not using the breeze-dark theme?

It’s better to create a test user and log in as that user and check (without any user level modifications). Login as root does not really help to determine if it’s at a system level or user level…

Try that and see if duplicates.

As I tried to explain already, I am not really interested in what reasons you give yourself for it. The only thing is that this way of working should not be propagated in these forums without comment so newbees should not learn bad practices.

I did create a regular user. The issue is still there.

(And I get it… you don’t want regular users logging in as root. But this is for support… for fixing things. Even in the Mac world, on the mac forums people dig in to the root user. On Windows forums, they even tell the beginners how to get in to the registry and fix things… With the warning that they could break things. But it’s not a blanket statement of sorry, no one can do any administrative functions on the computer because they might break something. I don’t see how that is helpful at all)

I’ll add a few details… I’m not great w/ this gui stuff… Don’t fully understand how the visual themes are applied…
I know of a few files which should be related…
In my home folder is the .gtkrc-2 file, which looks fine.
Then in /etc/gtk-2.0 is a system wide default file, which I’m not sure is even used.
Then in usr/share/themes are the folders containing the actual gtk theme files.

All the files match between my working and non working system…
Is there another location it might be getting the theme info?

I tried manually assigning the theme when running an app w/ the same results…
GTK2_RC_FILES=/usr/share/themes/Breeze-Dark/gtk-2.0/gtkrc deadbeef

And that’s where I ran out of ideas to try on my own.

Is the version of KDE Plasma and KDE Frameworks the same on the working and non working computer?

Everything is the same, other than old computer was UHD 630, and new us UHD 730.
I’m installing a new copy in a VM now, to see if it has the same issue.

It’s the same in the VM on another computer. SO, I think something w/ Opensuse has changed…
my working system is about 4 years old, and has been upgraded about weekly over the years… (zypper dup). I guess it used to work, and my working copy has been retained over the years… Just wish I could find what is different.

It is my understanding that KDE are no longer actively supporting theming of gtk2 applications:

Perhaps on your working (older) machine you still have some legacy packages? - Although if that is the case I’m afraid I’ve no idea what they may be.

You’ve no doubt already checked the likely candidates such as:

gtk2-metatheme-breeze and metatheme-breeze-common

If you create a new test user on your (older) working system is that user then able to apply a gtk2 breeze-dark theme, if so, that would point towards that machine perhaps having some legacy packages still installed.

I had the same issue, I posted a “dirty” way on the KDE Bug Fix you mentionned :

To make it quick, being root and overriding the default colors in the gtk2 folder of your light theme should work.
Of course there are side effects but that solution worked for me rotfl!

Kind Regards,


This issue affects Leap 15.4 too; both Breeze and Breze-Dark themes are installed, but systemsettings5 shows Breeze only. The strange thing is that both Adwaita and Adwaita-Dark themes are supported by systemsettings5.
In every case, your solution works perfectly.

There is also a simpler workaround.
For some strange reason, System Settings does not accept the name “Breeze-Dark” (/usr/share/themes/Breeze-Dark); a simple solution is to rename that directory (for example, as “BreezeDark”). At this point, both “Breeze” and “BreezeDark” themes will be available in System Settings.