New Firefox security requirements frustrating connection to UPS network card.

I find I can no longer connect to my UPS network card. It has a static or fixed IP and I usually access it by entering the IP address in my FF browser.

This no longer works and I cannot find an option to accept the risk and proceed.

Firefox suggests; Please contact the web site owners to inform them of this problem.

I guess this means me since the address is of my UPS.

I suspect the UPS network card is no longer supported so what do I do to access the UPS now please?


One does not test the connection to another partner on the network with Firefox (or any other browser). It maybe that the browser gives a problem, but you test if the other system is alive using ping:

ping -c <IP-address>

And of course replace <IP-address> with the IP address you think is the IP address of the other system.

What’s the exact error message from FF - perhaps you could post a screenshot?

I obviously can’t test using the hardware you have, but using FF (104.0.1) I’m able to connect to the admin pages of a Samsung Printer or of my Router/Cable Modem by using their respective IP addresses.

I wonder if Firefox now only allows https connections and his UPS is http. Mozilla and Google both have warned that http was going away someday.
Has someday arrived?

Hi Henk,
No problem seeing the device with ping but I need to open the app in the device which is why I use FF.
Will try different browser.

But you did not show anything. Not what you entered in the addressbar, Not what FF says as a result.
Only "This no longer works ". I slight variation on the infamous “It does not work”. Something even a car repair shop can do nothing with.

Hi Henk
This is what I entered in FF:-

This is the reply:-

Secure Connection Failed

An error occurred during a connection to PR_CONNECT_RESET_ERROR

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the web site owners to inform them of this problem.

Learn more…

You should have posted that in your first post. That would have save me the time to formulate my post #2.

Be glad I am not your car repair shop. That shop would put all time lost by forcing you to give the most basic information as working hours on the bill.

PR_CONNECT_RESET_ERROR basically means that “something” between FF and your UPS network card is terminating the connection forcibly.

Firewall, Antivirus Software, Proxy, VPN ??

Hi Henk,
Always good for a laugh!
I have tried using Chromium and I get a slightly different message:-

this site can’t be reached**** refused to connect.Try:

  - Checking the connection
  - [Checking the proxy and the firewall](


The Details page suggest I check firewall. At present I do not have any specific ports opened and am allowing http, https and nfs only.
What have I missed if this is the issue.


Hi Paul,

No proxy, vpn, or antivirus on this machine. Firewall; I cannot think what is missing and turning off makes no difference.

The route includes wifi link and vlans but the route is the same as for my wan connection.

Any other ideas?

Err… No, not offhand :\

Although the question comes to mind, as I assume this had been working, what has changed since then and now, or is it a case of seldom used and you’re unable to be specific about when it stopped working.

Are you sure you entered that exact code and not “https://”?
I’m asking because sometimes I have got a similar error message and my workaround (when sure it was safe) was to only use http not https.
In FF you may check in the security settings if you have “https-only” enabled. If yes, switch it off and try again with “http”.

Hi and thanks for this. Unfortunately I am still discovering security hurdles including the automatic adding of the “s” in http://. On laptop using TW and Firefox has been upgraded to v104. There are several significant changes from the Leap 15.3 version and I am still working through these but no luck so far. No time to give details but will post when I have an answer. What is strange however is that I cannot get Chromium to work either so perhaps this also has changed since I last used it.

Presupposing that was/is the problem for the UPS network card connect failure then as @kasi042 wrote, that (HTTPS Only Mode) can be changed from Settings -> Privacy & Security

If you want to still have HTTPS Only Mode enabled then you can set an “Exception” for URLs/IPs that you don’t want it applied to.

I linked already in comment 5# the discription of disabling HTTPS Only. But this may be not enough and you need also to disable HTTPS First as described in the article.

I know I sometimes miss some of the detail but I did not see any instructions on how to disable the HTTPS-First and anyhow I am not using Private Browsing.

All I want is to be able to find a browser that connects to my UPS as I used to be able to do as I need to be able to control it in urgent, albeit rare occasions.

If I could find a basic insecure browser that would work this might be the right solution for me rather than downgrading the normal settings on my FF installation.

If anybody has any suggestions please help.

Assuming that you have FF set to “Enable HTTPS-Only Mode in all windows” then you should be able to use the “Manage Exceptions…” button (shown in this screen shot - albeit greyed out there as I don’t have “HTTPS-Only Mode” enabled) to add the IP address of your UPS card.

Edit: New screen shot:

Hi Paul,
On further investigation it seems that the UPS NIC is the problem. Another UPS worked without even needing to set any exceptions. Will swap NICs so I can work on the problem device.
Sods law that the UPS I needed to power cycle is the one that has the problem but that’s the fun of networking!!!
Many thanks again.