New Acer 64bit laptop dual boot------ > GRUB Loading Stage 1.5 : Error 15

Hi Team,

Very Recent I’ve purchased a new Acer 64bit with nvidia graphics laptop waited for a long time to work with opensuse cloud technology(mirall). Unfortunately, I’m facing a new problem.

Might be a lengthy story :

Problem :

I’ve downloaded the new KDE 12.1 live CD iso file and burned it to a CD. Prior to the installation I’ve made a two partitions 400GB(Windows) and 190GB(Linux) in the windows. When booted through the CD I’ve choosen installation with default settings of kernel in the options it loaded the files for a while and a blank screen waited for long time but no progess.

Again I’ve booted and choosen the installation with safe mode installation. Then, selected the linux drive where the partition is splitted into 90GB for ext4 / and 30GB for / and 2GB swap space. But the windows drive have got paritioned into two (120GB and 190GB unallocated).

Installation is over and tried to boot with opensuse for the first time but it started throwing some error that /sbin/mod* process got killed, so again booted with fail mode with open suse, got into the tty without any problem. Then again rebooted and logged to windows7 where I’ve merged the unallocated space to the main C drive (120+190GB). Started to reboot again.

Booom…GRUB Loadin stage 1.5 : Error 15. No options on how to recover, got stuck.

No Idea what should I do…any help would be appreciated.

Regards,
AnuragSatish .P

Also the the graphics card version is GT520M with Optimus technology.

This will not work.

openSUSE 12.1 still uses legacy GRUB as boot manager,
which requires that boot partitions entirely are located below 128 GB.

Do it the other way round: create a partition setup where windows installs
in a partition below 128 GB and openSUSE 12.1 in a lower partition.

Another possibility would be to wait a bit of time for openSUSE 12.2,
which should include GRUB 2 boot manager, fixing problems of this kind.

Good luck
Mike

What ?!?!?

openSUSE 12.1 can indeed UEFI boot.

But otherwise … yes

EDIT: added version 12.1

128 GIG is a limit on old BIOS and should be no problem current machines. The installer does give a “WARNING” not an error message. Some BIOS simply do not handle it right.

I’m confused about this " two partitions 400GB(Windows) and 190GB(Linux) in the windows. …"

Linux requires a min of 2 partitions. and openSUSE defualts to 3 swap root and home

We need much more info. What type of BIOS and what type of disk formatting on this machine.

No you are wrong there is no 128 gig restriction on GRUB it may be a restriction on old BIOS

Otherwise … no. This warning is mostly irrelevant.

I just couldn’t get the openSUSE installer to finish its job,
until I created a partition setup with the ‘/’ partitions below 128 GB.

Does it mean that you don’t believe us? lol!

It’s not a question of belief: I just couldn’t get the openSUSE 12.1 installer finish its job.

May be that I did sth cruel, but in the end it probably was the 5th version of openSUSE that I installed,
and the possible ‘right way’ to do so didn’t seem to have been that obvious.

This warning is really irrelevant. Someone was just too lazy to remove it from the partitionner. It’s unlikely that people will combine an old BIOS which might still have this limitation with an HDD > 128 GB.

I guess last time I created any linux partition below 128 GB must have been ten years ago …
See where the extended partition starts in the example below. This mainboard is about 7 or 8 years old.

 # parted -l
Model: ATA WDC WD5000AAKS-0 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size    Type      File system     Flags
 1      32.3kB  263MB  263MB   primary   fat16           type=06
 2      37.9GB  184GB  146GB   primary   sun-ufs         type=a5
 3      185GB   237GB  51.5GB  primary   sun-ufs         type=a5
 4      237GB   500GB  264GB   extended                  boot, lba, type=0f
 5      237GB   239GB  2147MB  logical   linux-swap(v1)  type=82
 6      239GB   266GB  27.0GB  logical   ext4            type=83
 7      266GB   274GB  8593MB  logical   ext4            type=83
 8      274GB   291GB  17.2GB  logical   ext3            type=83
 9      291GB   325GB  33.0GB  logical   ext4            type=83
10      325GB   333GB  8590MB  logical   ext4            type=83
11      333GB   356GB  23.2GB  logical   ext4            type=83
12      356GB   361GB  4301MB  logical   ext4            type=83
13      361GB   394GB  33.0GB  logical   ext4            type=83
14      394GB   401GB  7532MB  logical   ext4            type=83
15      401GB   406GB  4433MB  logical   ext3            type=83
16      406GB   500GB  94.5GB  logical   ext4            type=83


It’s not a question of belief.
I just made different practical experiences.

I recently installed openSUSE 12.1 on a core i5-2000 PC with ASUS motherboard
capable of UEFI boot.
But in conventional (BIOS) boot mode I couldn’t get the openSUSE 12.1 installer
complete its job,
unless I provided a partition setup with openSUSE ‘/’ partition below 128 GB.

That’s just the way it was.

Which have led you to a wrong conclusion.

You were using UEFI compatibility support module, which emulates BIOS booting. But I don’t see why it would have such a limitation. And if it did, it would have been the exception - or maybe it does and we don’t know about it. But the limit for BIOS booting with MBR partitioning is 2 TiB, not 128 GiB. That’s just the way it is.

Hi Team,

The latest opensuse 12.1 is still considering to use the setup below first 128GB of the HDD.

I’ve found out the problem is that my nvidia GT520M optimus drivers are not supported with opensuse which uses nouveau as default graphics display drivers. Went through couple of threads and installed some packages using text-mode in fail-safe mode after deleting the existing linux os in laptop with disc installation.

Now I’m able to login through normal boot to suse KDE desktop but still getting some error while installing the 64bit GT500 series downloaded from nvidia site.

Errors what errors. Really if you want help you have to tell use the error, we can not see over you shoulder and all are crystal balls are broken.

Hi, Sorry for the late reply. As I’ve told earlier, we’ve installed kernel-desktop,kernel-devel etc., kernel files. Then logged through safe-mode(fail-safe) installed nvidia GT520M drivers succesfully.Earlier the error was to that I need to quit Xserver first. Did that n installed the driver.When booted normally, to the desktop opensuse 3 latest version it has thrown some errors and showing tty1 cli mode login mode.Please find below errors : Error : Invalid iomem sizeError : Enabled SSC on PH systemd-fsckError : MUX info call failedError : VirtualBox guest PCI device not found.Please suggest me any solution to get through.Regards,AnuragSatish .P

Someone help me got stuck don’t know wht to do?

Hi I’m back for a few days.

To me the point seems to be:

In UEFI boot, openSUSE 12.1 uses ELILO, which runs fine.

But booting openSUSE 12.1 the conventional way, still legacy GRUB is used, right?

openSUSE 12.2 will have GRUB 2, overcoming things like the 128GB limit. Right as well?

So, waiting just bit more until openSUSE 12.2 finally comes out really may help a lot.

All the best
Mike

128 gig limit is not a limit on grub it is a limit imposed by some old BIOS not any new ones. The installer just gives a warning not an error.