NetworkManager won't connect to some APs

Dear all,

I am experiencing troubles when connecting to my new private network under Linux (works fine with Windows). I cannot get an ip address and the logs tell me a bit more, but I would like to know how to proceed to resolve this issue. My network adapter is an Intel Wifi Link 5100 using the iwlagn driver. Connecting to other WEP APs usually works flawless, it’s the first time my system won’t connect at all to this particular WEP encrypted access point.

Thank you in advance for your support and best regards,
Quentin

Logs: NetworkManager: pastebin - collaborative debugging tool
wpa_supplicant: pastebin - collaborative debugging tool

Have you tried taking WEP away?
WEP is so good it’ll not make any difference that it’s not there.

Or better use WPA

I am not administrator of that accesspoint, unfortunately. It is a shared connection for the building I am living in. I really want fix this problem since I am currently unable to use Internet on my SuSE box. How can I debug further this problem?

I had this problems previously. I do not know it you are using the 11.1 or 11.2 as you did not specify.
However, I had this problem with 11.1 always, over and over, mostly in Spain, Italy and France where AP points with Web are common especially in Hotels or like in your case in private shared connections.
I tried at the time an alternative WLAN manager that did actually help (but the /etc.resolve.conf did not work then (and at the time) I did not know how to handle it).
If you have 11.2 you should try KDE4.4 when it comes out (shortly in February). They have changed the code for networkmanager consistently in that edition. If you cannot (or if you have 11.1) you may opt for a alternative network-manager or try to speak with the admin, if you are on the same electrical line, you could take the signal through a d-lan connection. You could also try to use a repeater as the connection problem is (for my experience) quite specific to the material used in the AP, so your PC might connect to the repeater but not to the AP.

Install WICD, it helped me when the networkmanager failed to do the job.

No, wicd has exactly the same problem. I have the impression the problem is driver related, but how is this prossible? Is there any other driver out there for my card? How can I workaround this issue?

Is there any issues with the capabilities of your card?

su
iwconfig

In the output, look for something like “IEEE 802.11abgn”.

Also, see if the network is visible when you scan it.

iwlist scan

ifconfig: pastebin - collaborative debugging tool
iwlist wlan0 scan: pastebin - collaborative debugging tool

but I doubt this will really help us solving the driver problem… I’m really stuck with that issue, I am really fed up with wifi troubles.

The problem isn’t the connection. It is detecting and connecting the wireless connection. The problem is the authentication. Your at the walled garden Walled garden (technology) - Wikipedia, the free encyclopedia

What this means is that either the wep password is wrong, or you are using the wrong wep encryption. It should be set up something like this. http://img682.imageshack.us/img682/5860/wirelessy.th.jpg](http://img682.imageshack.us/i/wirelessy.jpg/)

It won’t make any difference whether you use WICD or networkmanager. The picture in this post is of networkmanager. Notice how I have it set in the picture.

Use wireless security is checked (obviously).
The drop down menu is on WEP.
Authentication is set to open system.
type is set to WEP 40/128-bit hexidecimal.
then you just enter the wep key into key 1:.