NetworkManager "seems" to fail at boot

after the recent zypper dup to tumbleweed 20230816 I’m getting an error message at boot time for NetworkManager.

chris@asus-roc:~>$systemctl status NetworkManager-wait-online.service
× NetworkManager-wait-online.service - Network Manager Wait Online
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; enabled; preset: disabled)
     Active: failed (Result: exit-code) since Sun 2023-08-20 08:28:45 AWST; 30min ago
       Docs: man:NetworkManager-wait-online.service(8)
    Process: 1209 ExecStart=/bin/bash -c if [ ${NM_ONLINE_TIMEOUT} -gt 0 ]; then /usr/bin/nm-online -s -q --timeout=${NM_ONLINE_TIMEOUT} ; else /bin/true ; fi (co>
   Main PID: 1209 (code=exited, status=1/FAILURE)
        CPU: 14ms

Aug 20 08:28:15 asus-roc.lan systemd[1]: Starting Network Manager Wait Online...
Aug 20 08:28:45 asus-roc.lan systemd[1]: NetworkManager-wait-online.service: Main process exited, code=exited, status=1/FAILURE
Aug 20 08:28:45 asus-roc.lan systemd[1]: NetworkManager-wait-online.service: Failed with result 'exit-code'.
Aug 20 08:28:45 asus-roc.lan systemd[1]: Failed to start Network Manager Wait Online.

Booting hangs for about 30secs at this point then proceeds normally. Once logged in networking seems ok - I can surf the web etc.

Is this new error non-fatal or is there something more to check?


There’s been two updates since 0816 … have you run a dup for the latest version to see if it’s fixed?

I’m seeing that on every boot (with Leap 15.5). It doesn’t seem to cause problems. Network seems to function as expected.

I’m using “sendmail” for mail, and I do seem to need

systemctl restart sendmail

after startup, for it to work properly. I have not noticed any other issues.

Gad, I barely survived the last massive 3,900 packages dup :slight_smile:

I’ll do anothe dup tonight.

Yeah, not problem so far but it’s annoying with the boot process hanging 30secs. Before booting zipped by.

1 Like

As a point of contrast, my desktops use Wicked …

My laptops use NM. Immediately after the massive dup, I lost network connection (even before I rebooted).

However, after the reboot, NM worked as expected, with no boot delays. Next time I fire up a laptop, I’ll check the logs for the warning/error.

@kitman Look at /etc/sysconfig/network/config I use;


I generally disable the NetworkManager-wait-online.service on all of my machines…
It only makes the boot process longer. If you deactivate it, your system wont wait for the network to be up before it boots into graphical mode. Disabling the service has generally no side effects (but can be reverted “if”). Your network will be up nevertheless when you reached the graphical target…

1 Like

Hm, my config file - dated yesterday I assume due to the dup - has a value of 30 for both. OK, I can adjust those.

Curious how long ago did you set yours?

Thanks, I’ll test that too.

@kitman yes default is 30, change to the values as suggested :wink:

Um, it’s been a while - should I edit that file directly or is their an override file in ~/.config?

@kitman edit direct…

Thanks all. I’ll followup tomorrow.

In the end I went with @hui suggestion of disabling this service. My boot time is now very fast again (seems faster maybe :wink: ) and there’s no apparent detriment to connectivity.

Many thanks to all.

Today I ran dup to version 20230823. Problem persists.

I’m sticking with @hui’s method of disabling the NetworkManager-wait-online.service.

Thanks for posting this. After a recent dup I found booting to be quite slow. Googling revealed a lot of waving of magic chicken feet for similar NetworkManager related symptoms. Turning off NetworkManager-wait-online.service is what did the trick for my desktop.

In my situation, a desktop with no NFS/SMB mounts, I don’t see the service as necessary, so I’ll probably leave it masked off permanently. What I did (as root/sudo):

systemctl mask NetworkManager-wait-online.service

Back to 6 second boots. No noticeable issues with graphical logins or networking.

@mchnz Because you have a desktop PC, which most likely needs no network “management” being in the same place on the same net all the time, you have another option: remove both NetworkManager and Wicked. Install systemd-network. Enable systemd-networkd.socket. Configure your NIC in /etc/systemd/network/. Purge or disable everything to do with resolv.conf so that you can create a static resolv.conf. That’s all it takes. You may simply forget about any need to “manage” your network (or using YaST for that purpose - it doesn’t know about systemd-network yet).

Thanks. I did briefly try systemd-network a few years back when I was attempting to speed up booting. The change didn’t seem substantially faster to boot, so I figured I’d stay more Tumbleweed mainstream and returned to NetworkManager. It’s nice to be spoilt for choice, back then I had a play with all three.

As well as Ethernet, my desktop also has Wi-Fi, which I can use as a fallback and as a way to talk to my camera. I do quite like the little KDE Networks tray tool which I presume works with NetworkManager.

Now that boot times are back in the 6 second ballpark, I’m happy to leave it as is.