NetworkManager freezed and how to resolve it without rebooting

After the system running whole night, I found I cannot switch wifi by network manager. And when I open the UI of network manager, there is a text on the UI after a long time: NetworkManager needs to be running.

Then I run:

systemctl restart network

The command hangs there, no any response

Then I run:

systemctl status network

I get:


and some PID in above content

I use:

systemctl kill NetworkManager


kill -9 <PIDs in above status info>

I found I cannot kill these processes

Then I use:

systemctl daemon-reload
systemctl daemon-reexec

The status of NetworkManager service becomes to: inactive


systemctl restart network

I was told:

Job for NetworkManager failed because the control process existed with error code

Finally I run:

journalctl -xe

Found left-over process xxx (NetworkManager) in control group while starting unit. Ignoring.

NetworkManager.service: Failed with result ‘exit code’

Failed to start Network Manager


If you don’t know what is causing your networking problems,
Then sometimes the only practical solution is to power off and back on, aka a “hard boot.” A simple reboot (aka Soft boot) may or may not be sufficient.
This is especially because your description suggests orphaned processes. Although systemd tries to minimize the creation of orphaned processes, it can still happen and then it’s nearly impossible to kill those processes without a reboot.