Networking with WinXP

After getting tired of ubuntu i’ve decided to switch to SuSE, and I must say I’m very happy with the results. My only issue I have left is connecting to my windows xp computer.

on ubuntu, my windows network was automatically found and i was able to access the shared folders with ease. well the same story can’t be said for suse, i’ve read a few tutorials about setting up a samba server and things like that but still no luck.

when i open my file manager, and go to network it has a Windows Network icon, when I open it up I see the workgroup name of the windows xp machine, MSHOME, but when I try to gain access to it, i receive an unable to mount server error.

are there any good tutorials for this? I know the windows xp machine is set up to allow anybody to access the shared folders that are on the server. my windows 7 connects to it just fine, and so did ubuntu before, can anybody point me in the right direction for resolving this?

thanks in advance, matt.

Check samba allowed through firewall: netbios-server, samba-server, samba client
Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 11.x
Few other things to check out there too, e.g. is the workgroup the same, is netbios name set, is name resolve order set to “name resolve order = bcast host lmhosts wins”.

My money is on the either (1) workgroup name being the same and/or (2) the firewall settings, but can’t properly remember.

Thanks for the link and assistance. My confusion is the netbios name, is that basically the name of my SuSE server?
I allowed firewall through samba settings, but I haven’t configured the firewall itself just yet, I didn’t think that’d be an issue, but I’ll definitely check it out.

I’ll try what you’ve suggested and let you know, once again, thanks.

is that basically the name of my SuSE server?
Yes, not necessarilty, but normally, yes. You can set it in the file smb.conf – however it’s not really key to your problem. IIRC Gnome likes to say use error if the firewall is blocking or workgroups differ.

You might also read this tread. I ran into some trouble while setting up my Samba network. These replys were a God sent! AppArmor was the trouble. Had to either change some settings or turn it off.
Samba setup help